Cyberduck Mountain Duck CLI

#2612 closed defect (worksforme)

Upload contains garbage in code

Reported by: jpm@… Owned by: dkocher
Priority: normal Milestone:
Component: core Version: 3.0.2
Severity: major Keywords:
Cc: Architecture:
Platform:

Description

I upload a PHP page which already exists on the server. It asks if I want to replace it so I click OK. I then test the newly uploaded page by accessing it from the Web browser and it gives a PHP error. After looking at the page (downloading it from the server to my desktop), I noticed it had some PHP code thrown in the middle of the page (which actually belongs at the bottom of the page), thus throwing a PHP syntax error. The code was correct on my local machine before I uploaded it. But after it was uploaded something got mixed up along the way.

To fix, I have to first delete the file from the server and then upload it again. It seems to be fine after doing that.

This doesn't always happen, but I have had it happen on at least 2 occasions. (It may be after the server failed to login the first time to the SSH account, but I haven't been able to confirm that).

Change History (2)

comment:1 Changed on Oct 7, 2008 at 9:02:45 PM by jpm@…

  • Severity changed from normal to major

I have not confirmed this, but it may be due to the fact that some of the files have Windows line feed/breaks, while others Unix or Mac.

It's really be doing it a lot lately, and very very annoying. The only work-around is to delete the file from the server first.

comment:2 Changed on Oct 18, 2008 at 1:43:18 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Maybe the line ending conversion is the culprit. Then make sure to Binary as the transfer mode in the FTP Preferences.

Note: See TracTickets for help on using tickets.
swiss made software