Cyberduck Mountain Duck CLI

#2635 closed defect (fixed)

CyberDuck crashes frequently

Reported by: xurizaemon Owned by: dkocher
Priority: normal Milestone: 3.0.3
Component: core Version: 3.0.2
Severity: normal Keywords: crash
Cc: der.ozean@… Architecture:
Platform:

Description (last modified by dkocher)

Hi, I love Cyberduck dearly, but it crashes on me most sessions.

Typically I'm using it to edit remote textfiles via SSH in TextWrangler. I'm using OSX10.5.4; I've observed this behaviour on both 10.4 and all previous versions of 10.5. I've seen this behaviour across many different versions of Cyberduck, on (at least) three different OSX machines.

Generally it happens when changing to another folder, or opening a file to edit via CMD+J.

    Process:         Cyberduck [81772]
    Path:            /Applications/Cyberduck.app/Contents/MacOS/Cyberduck
    Identifier:      ch.sudo.cyberduck
    Version:         3.0.3 (4180) (4180)
    Code Type:       X86 (Native)
    Parent Process:  launchd [155]

    Date/Time:       2008-10-02 22:47:10.459 +1300
    OS Version:      Mac OS X 10.5.4 (9E17)
    Report Version:  6

    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x00000000c52cc9a7
    Crashed Thread:  0

    Application Specific Information:

    Java information:
    Version: Java HotSpot(TM) Client VM (1.5.0_13-119 mixed mode, sharing)
    Virtual Machine version: Java HotSpot(TM) Client VM (1.5.0_13-119) for macosx-x86, built on Sep 28 2007 23:59:21 by root with gcc 4.0.1 (Apple Inc. build 5465)
    Exception type: Bus Error (0xa) at pc=0x53d08c80

    Current thread (0x01a01310):  JavaThread "main" [_thread_in_native, id=-1601622112]
    Stack: [0xbf800000,0xc0000000)
    Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
    j  com.apple.cocoa.application.NSApplication.sendEvent(Lcom/apple/cocoa/application/NSEvent;)V+0
    j  ch.cyberduck.ui.cocoa.CDMainApplication.sendEvent(Lcom/apple/cocoa/application/NSEvent;)V+163
    v  ~StubRoutines::call_stub
    Java Threads: ( => current thread )
      0x01a2b9e0 JavaThread "Thread-23" daemon [_thread_in_native, id=9875968]
      0x01a1eb70 JavaThread "Thread-14" daemon [_thread_in_native, id=8568320]
      0x01a19140 JavaThread "Thread-6" [_thread_in_native, id=-1331851264]
      0x01a18020 JavaThread "Thread-4" [_thread_in_native, id=9432064]
      0x01a17b10 JavaThread "Thread-3" [_thread_in_native, id=9428480]
      0x01a17770 JavaThread "Thread-2" [_thread_in_native, id=9653248]
      0x01a170b0 JavaThread "Thread-1" [_thread_in_native, id=9649664]
      0x01a0b880 JavaThread "Thread-0" daemon [_thread_in_native, id=-1337421824]
      0x01a08f00 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=8518656]
      0x01a084d0 JavaThread "CompilerThread0" daemon [_thread_blocked, id=8515072]
      0x01a07fd0 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=8508928]
      0x01a07800 JavaThread "Finalizer" daemon [_thread_blocked, id=8502784]
      0x01a07420 JavaThread "Reference Handler" daemon [_thread_blocked, id=8499200]
    =>0x01a01310 JavaThread "main" [_thread_in_native, id=-1601622112]
    Other Threads:
      0x01a06b70 VMThread [id=8495616]
      0x01a09b00 WatcherThread [id=8522240]

    VM state:not at safepoint (normal execution)
    VM Mutex/Monitor currently owned by a thread: None

    Heap
    def new generation   total 576K, used 476K [0x25580000, 0x25620000, 0x25a60000)
      eden space 512K,  87% used [0x25580000, 0x255efb30, 0x25600000)
      from space 64K,  45% used [0x25610000, 0x256175a0, 0x25620000)
      to   space 64K,   0% used [0x25600000, 0x25600000, 0x25610000)
    tenured generation   total 3840K, used 2856K [0x25a60000, 0x25e20000, 0x29580000)
       the space 3840K,  74% used [0x25a60000, 0x25d2a3c0, 0x25d2a400, 0x25e20000)
    compacting perm gen  total 8192K, used 7500K [0x29580000, 0x29d80000, 0x2d580000)
       the space 8192K,  91% used [0x29580000, 0x29cd3350, 0x29cd3400, 0x29d80000)
        ro space 8192K,  63% used [0x2d580000, 0x2da96c48, 0x2da96e00, 0x2dd80000)
        rw space 12288K,  43% used [0x2dd80000, 0x2e2af088, 0x2e2af200, 0x2e980000)

    Virtual Machine arguments:
    Java command: <unknown>
    launcher type: generic


    Thread 0 Crashed:
    0   libObjCJava.A.dylib              0x53d08c80 NSIdToJavaHandle + 18
    1   libObjCJava.A.dylib              0x53d0cfdb _BRIDGEMorphObjcArgumentsForJava + 833
    2   libObjCJava.A.dylib              0x53d0da4a _NSInvokeJavaMethod + 718
    3   libObjCJava.A.dylib              0x53d09591 _BRIDGEMethodImp + 181
    4   com.apple.AppKit                 0x959464d6 -[NSOutlineView _dataSourceValueForColumn:row:] + 99
    5   com.apple.AppKit                 0x95946100 -[NSTableView preparedCellAtColumn:row:] + 188
    6   com.apple.AppKit                 0x959c972c -[NSTableView _hitTestForEvent:atColumn:row:] + 56
    7   com.apple.AppKit                 0x959c9564 -[NSTableView canDragRowsWithIndexes:atPoint:] + 415
    8   com.apple.AppKit                 0x959c903c -[NSTableView _performDragFromMouseDown:] + 218
    9   com.apple.AppKit                 0x959c718a -[NSTableView mouseDown:] + 741
    10  com.apple.AppKit                 0x959d8d75 -[NSOutlineView mouseDown:] + 611
    11  com.apple.AppKit                 0x9597f88b -[NSWindow sendEvent:] + 5381
    12  com.apple.AppKit                 0x9594c431 -[NSApplication sendEvent:] + 2941
    13  libAppKitJava.B.dylib            0x50c0a60e Java_com_apple_cocoa_application_NSApplication_sendEvent + 230
    14  ???                              0x03d859b1 0 + 64510385
    15  ???                              0x03d7f9d3 0 + 64485843
    16  ???                              0x03d7d227 0 + 64475687
    17  libjvm.dylib                     0x004d263a 0x3b9000 + 1152570
    18  libjvm.dylib                     0x004d2356 0x3b9000 + 1151830
    19  libjvm.dylib                     0x0045c68c 0x3b9000 + 669324
    20  libjvm.dylib                     0x005c973b JNI_CreateJavaVM_Impl + 106747
    21  libObjCJava.A.dylib              0x53d06c6d __JAVAMethodInvoke + 173
    22  libObjCJava.A.dylib              0x53d070cd JAVAMethodInvokeVoid + 69
    23  libObjCJava.A.dylib              0x53d0dd03 _NSInvokeJavaMethod + 1415
    24  libObjCJava.A.dylib              0x53d09591 _BRIDGEMethodImp + 181
    25  com.apple.AppKit                 0x958a9e27 -[NSApplication run] + 847
    26  com.apple.AppKit                 0x95877030 NSApplicationMain + 574
    27  ch.sudo.cyberduck                0x00002de3 _start + 209
    28  ch.sudo.cyberduck                0x00002d11 start + 41

Change History (11)

comment:1 Changed on Oct 7, 2008 at 11:58:13 AM by anonymous

  • Keywords crash added

PS. Attempting to attach files directs me to an error handler - you can replicate this by hitting the "Attach file" button above.

Fortunately, a zipfile of some crash logs is already available here

My Cyberduck version is 3.0.3 (4180), but that version isn't available in the "Version" selector, so I've selected the most similar value.

comment:2 Changed on Oct 7, 2008 at 12:01:46 PM by anonymous

Probably duplicates: #2562, #2617, #2593, #2563, #2562

I'm upgrading to the latest nightly build (r4189 currently) to test now. Will report back.

comment:3 Changed on Oct 7, 2008 at 12:26:20 PM by anonymous

Also dupes #2142, noting that one user reports downgrading to 2.8.5 as a successful workaround for him.

I still found that r4189 crashed for me after only a few minutes of use. As described by others in #2142, it was shortly after switching back to Cyberduck from another app.

comment:4 Changed on Oct 7, 2008 at 2:06:45 PM by dkocher

Thanks a lot for your anlaysis on the issue. The problem is that although I have many crash reports, they do not reveal the real cause of the issue and I am not able to replicate the crash on my own systems.

I propose that you try with a fresh account on your OS X installation (System Preferences > Accounts) so we can rule out a issue with preferences etc.

comment:5 follow-ups: Changed on Oct 8, 2008 at 8:29:34 PM by xurizaemon

I was skeptical of this, because I remembered having cleared a Cyberduck prefs file out of my home folder in a previous attempt, and it didn't do the trick.

However, I did as you suggest, and Cyberduck + Textmate co-operated for a couple of hours. Hardly scientific, but certainly far longer than typical for me currently.

I'd be happy to send you my prefs file(s) if you can confirm that there are no keys / sensitive data contained?

Best not to attach here, though. Btw, are you aware that attachments are not working (for me at least) in this Trac?

comment:6 Changed on Oct 8, 2008 at 9:25:04 PM by dkocher

  • Description modified (diff)

comment:7 in reply to: ↑ 5 Changed on Oct 8, 2008 at 9:28:22 PM by dkocher

Replying to xurizaemon:

I was skeptical of this, because I remembered having cleared a Cyberduck prefs file out of my home folder in a previous attempt, and it didn't do the trick.

However, I did as you suggest, and Cyberduck + Textmate co-operated for a couple of hours. Hardly scientific, but certainly far longer than typical for me currently.

I'd be happy to send you my prefs file(s) if you can confirm that there are no keys / sensitive data contained?

Best not to attach here, though. Btw, are you aware that attachments are not working (for me at least) in this Trac?

The preferences file contains no personal data. All credentials are stored in the Keychain and bookmarks in a separate file in Application Support/Cyberduck. Please mail to dkocher@….

comment:8 Changed on Oct 9, 2008 at 8:33:19 PM by ozean

  • Cc der.ozean@… added

comment:9 in reply to: ↑ 5 Changed on Oct 10, 2008 at 6:02:21 PM by dkocher

Replying to xurizaemon:

However, I did as you suggest, and Cyberduck + Textmate co-operated for a couple of hours. Hardly scientific, but certainly far longer than typical for me currently.

Have you had any crashes since with the same usage pattern?

comment:10 Changed on Oct 14, 2008 at 11:20:09 PM by xurizaemon

As reported in the related forum thread, since downloading r4198 I've had no crashes for several hours of use.

This is significantly longer than I've had previously. I suspect you've nailed it; good work.

Will report back if any change.

Recommend people download a nightly build if they are experiencing this issue - r4198 is available here, or you might check to see if there's a more recent nightly build.

Thanks!

comment:11 Changed on Oct 17, 2008 at 9:22:43 PM by dkocher

  • Milestone set to 3.0.3
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software