Cyberduck Mountain Duck CLI

#2697 closed defect (worksforme)

Uploaded files act as directories

Reported by: scott@… Owned by: dkocher
Priority: highest Milestone:
Component: ftp Version: 3.0.2
Severity: critical Keywords:
Cc: Architecture:
Platform:

Description

When uploading some files (PDF, zip, etc.) cyberduck uploads in a way that the server thinks they are folders.

When creating a url link to the file, the www server thinks you are trying to view a folder.

Verified on ipower.com servers.

Change History (4)

comment:1 Changed on Oct 29, 2008 at 9:52:33 PM by dkocher

  • Component changed from core to ftp

Please post the transcript from View → Log Drawer.

comment:2 Changed on Nov 10, 2008 at 2:38:11 PM by dkocher

220 IPOWER FTP Server ready
USER discovercore
331 Password required for discovercore
PASS ********
230 User discovercore logged in
NOOP
200 NOOP command successful
SYST
215 UNIX Type: L8
STAT /public_html/files
211-Status of /public_html/files:
 drwxr-xr-x   4 223950   15000        8192 Oct 30 11:52 .
 drwxr-xr-x  36 223950   15000        4096 Aug 19 11:43 ..
 -rw-rw-rw-   1 223950   15000    26743214 Oct  3 11:34 2_color_grate.zip
 -rw-r--r--   1 223950   15000    160439419 Oct 29 18:44 401728.zip
 -rw-r--r--   1 223950   15000    10258113 Oct 28 18:34 Archive.zip
 -rw-rw-rw-   1 223950   15000     4400071 Oct 29 12:29 AuthenticHelmets-v1-102708.2_print.pdf
 drwxr-xr-x   8 223950   15000        4096 Oct 17 13:37 BB
 -rw-rw-rw-   1 223950   15000    16592252 Oct  3 14:53 BD_Brochure.zip
 -rw-rw-rw-   1 223950   15000     7148861 Sep 19 12:52 BatSheets_091908.zip
 -rw-r--r--   1 223950   15000    57116522 Sep 30 09:12 BeerSellSheet.zip
 -rw-r--r--   1 223950   15000     3655190 Oct 23 22:53 BodyDynamicsV3.psd.zip
 -rwx------   1 223950   15000    22932170 Oct 14 13:41 BuyTheBest.zip
 -rw-rw-rw-   1 223950   15000    22932170 Oct 14 14:25 BuyTheBest_PrintPDFs.zip
 -rw-r--r--   1 223950   15000     3013829 Oct  7 17:57 Clutch_EPS.zip
 -rw-r--r--   1 223950   15000    32792099 Oct  6 15:53 EPSFile_CS1.ai.zip
 -rw-rw-rw-   1 223950   15000     9531080 Oct  6 13:03 Ergo2008Bro-vL-100608.pdf
 -rw-rw-rw-   1 223950   15000    10325847 Oct 29 17:58 Ergo2008Bro-vL-102808.pdf
 -rw-r--r--   1 223950   15000    13338337 Oct 30 09:21 GerryDavisCover_09.zip
 -rw-r--r--   1 223950   15000    13629725 Oct 10 10:24 GrizzDemos.zip
 -rw-r--r--   1 223950   15000    15689555 Oct 28 13:16 JamLandingPage.zip
 -rw-rw-rw-   1 223950   15000     8794122 Oct 29 12:31 LaptopSkinz_WalMart_4up.pdf
 -rw-r--r--   1 223950   15000    78757748 Sep 29 08:16 MicrobanBrochure.zip
 -rw-r--r--   1 223950   15000     7089693 Oct  2 00:43 MobileArmorConcepts.zip
 -rw-rw-rw-   1 223950   15000    101748884 Oct 28 18:04 Quill_Landing.zip
 -rw-rw-rw-   1 223950   15000       14292 Oct  2 17:22 Quill_Zone-7_100208.jpg
 -rw-r--r--   1 223950   15000    28418410 Oct 13 15:24 SPR_WHWN_Cover.zip
 -rw-rw-rw-   1 223950   15000     9059524 Sep 29 17:24 SalesMeetingSignage.zip
 -rw-r--r--   1 223950   15000    11643868 Oct 23 14:49 SellSheetChanges.pdf
 -rw-r--r--   1 223950   15000    36051274 Oct 24 14:11 ShredderMM.zip
 -rw-r--r--   1 223950   15000     3885748 Oct 13 12:03 StaplesCover_OPMA.zip
 -rw-r--r--   1 223950   15000     8581149 Oct 29 14:59 StripGraphics.psd.zip
 -rw-r--r--   1 223950   15000     4403753 Oct 24 10:03 TV_Graphics.zip
 -rw-rw-rw-   1 223950   15000    133729940 Oct  1 12:29 TandC_brochure_8-093008.pdf
 -rw-rw-rw-   1 223950   15000    18495228 Oct  1 13:56 TandC_brochure_8-093008_web.pdf
 -rw-r--r--   1 223950   15000    47882109 Sep 26 14:29 UmpCover2009Images.zip
 -rw-r--r--   1 223950   15000     9011809 Sep 22 22:47 WB_Mason.zip
 -rw-rw-rw-   1 223950   15000    340975166 Oct  2 13:32 Wilson-100208.zip
 -rw-rw-rw-   1 223950   15000    28661223 Oct  6 11:14 Wilson-100608_PDF.zip
 -rw-r--r--   1 223950   15000    12353536 Oct 24 17:47 WilsonImages_GerryDavis.zip
 -rw-r--r--   1 223950   15000     4363947 Oct 24 17:48 WilsonImages_GerryDavis_jpgs.zip
 -rw-r--r--   1 223950   15000     7694444 Oct 10 10:29 backgroundRevise.zip
 -rw-r--r--   1 223950   15000    177328926 Oct 30 12:30 beverage.zip
 -rw-r--r--   1 223950   15000      397326 Sep 26 12:31 comfort_prod.zip
 -rw-r--r--   1 223950   15000           0 Oct 14 14:13 index.html
 -rw-rw-rw-   1 223950   15000     9189514 Oct  1 17:28 industrial_wallpaper 2C_k_877_print.pdf
 -rw-r--r--   1 223950   15000     5124610 Oct  8 16:17 jamproof.zip
 -rw-r--r--   1 223950   15000     3764095 Oct  8 16:37 officeSol.zip
 -rw-r--r--   1 223950   15000      148999 Oct 14 14:20 pedobear.png
 drwxr-xr-x   3 223950   15000        4096 Sep 26 17:46 quillbanners
211 End of status

comment:3 Changed on Nov 10, 2008 at 2:38:52 PM by dkocher

Which of the files in the above transcript are displayed as folders?

comment:4 Changed on Mar 21, 2009 at 12:49:27 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Please contact your web hosting service provider for assistance if the issue is with the web server and not related to browsing the files with Cyberduck.

Note: See TracTickets for help on using tickets.
swiss made software