Cyberduck Mountain Duck CLI

#2740 closed defect (worksforme)

Directories with extended attributes don't upload

Reported by: tomldavis@… Owned by: dkocher
Priority: normal Milestone:
Component: sftp Version: 3.0.3
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

I can't upload (sftp) directories with extended attributes. In particular, I find that directories with the 'com.apple.FinderInfo' attribute set (found using ls -@l or xattr) will not upload to a Redhat box. The Log window is empty after an upload try, but the Transfers window says

Transfer incomplete 0 B of 0 B

Change History (4)

comment:1 Changed on Nov 16, 2008 at 2:54:41 PM by dkocher

  • Description modified (diff)

I cannot replicate this. Can you find any related output in the console.log (/Applications/Utilities/Console.app)?

comment:2 Changed on Nov 17, 2008 at 8:54:25 PM by dkocher

Posting reply from email:

Can't find anything in the Console (looked in All Messages, Console Messages & system.log). Rebooted; no change. Tried both drag-and-drop and File>Upload...; no difference. Tried several different directories with the com.apple.FinderInfo attribute; same behavior. AFAIK, I have no risky software installed (like an Input Manager). I do have a USB to serial kernel extension installed: ProlificUsbSerial.kext ver 1.2.1.

From the Transfers window:

URL:		sftp://nemesis/home/dave/tdavis
Local File:	/Volumes/wlan					<--- This doesn't look right, local directory is '/Users/tom/MATLAB/Work/wlan'

Sorry I didn't notice this before.

In all failed attempts, the Local File is listed as being in /Volumes. Partially successful uploads list the Local File path correctly. (I have quite a few transfers listed as 'Transfer incomplete', e.g. Transfer incomplete, 1.2 KB of 1.2 KB, but the transfer seems to be usable.)

More info:

MacBookPro:Work tom$ GetFileInfo wlan
directory: "/Users/tom/MATLAB/Work/wlan"
attributes: avbstclINMedz
created: 10/29/2005 03:09:47
modified: 10/29/2005 03:09:47
MacBookPro:Work tom$ xattr -l wlan
com.apple.FinderInfo:
0000   01 CB 00 04 03 05 01 8E 03 E0 FF FF FF FF 02 07    ................
0010   FF FC FF EA C3 40 00 00 00 00 80 ED 00 00 00 00    .....@..........
MacBookPro:Work tom$ ls -@l
drwxr-xr-x@  31 tom  admin  1054 Oct 29  2005 wlan
	com.apple.FinderInfo	  32

comment:3 Changed on Nov 13, 2009 at 10:10:47 PM by dkocher

Do you still have this issue in version 3.3?

comment:4 Changed on Dec 29, 2009 at 6:09:51 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Seems to be a similar issue to #3192.

Note: See TracTickets for help on using tickets.
swiss made software