Cyberduck Mountain Duck CLI

#2863 closed defect (fixed)

iDisk Upload Incompatibility

Reported by: grosti@mac.com Owned by: dkocher
Priority: normal Milestone: 3.1.1
Component: webdav Version: 3.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Hello,

FYI I've just installed CyberDuck v 3.1 and I'm getting an error while trying to upload a single file to my iDisk, to substitute an existing one already in place. I went back to v. 3.0.3 and everything is fine again.

Giorgio

  • FULL TRANSCRIPT
PROPFIND /grosti HTTP/1.1[\r][\n]
Authorization: Basic Z3Jvc3RpOmdyZ3JzdDE4ZXA=[\r][\n]
Content-Type: text/xml; charset=utf-8[\r][\n]
User-Agent: Cyberduck/3.1 (4448)[\r][\n]
Host: idisk.mac.com[\r][\n]
Content-Length: 207[\r][\n]
Depth: 0[\r][\n]
[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
Server: AppleIDiskServer-1D2305[\r][\n]
x-responding-server: sslng106[\r][\n]
X-dmUser: grosti[\r][\n]
Content-Location: /grosti/[\r][\n]
Content-Type: text/xml;charset=utf-8[\r][\n]
Content-Length: 583[\r][\n]
Date: Fri, 09 Jan 2009 11:41:02 GMT[\r][\n]
[\r][\n]
PROPFIND /grosti/Web/Sites/iWeb/Pm-it/ HTTP/1.1[\r][\n]
Authorization: Basic Z3Jvc3RpOmdyZ3JzdDE4ZXA=[\r][\n]
Content-Type: text/xml; charset=utf-8[\r][\n]
User-Agent: Cyberduck/3.1 (4448)[\r][\n]
Host: idisk.mac.com[\r][\n]
Content-Length: 207[\r][\n]
Depth: 0[\r][\n]
[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
Server: AppleIDiskServer-1D2305[\r][\n]
x-responding-server: sslng106[\r][\n]
X-dmUser: grosti[\r][\n]
Content-Type: text/xml;charset=utf-8[\r][\n]
Content-Length: 604[\r][\n]
Date: Fri, 09 Jan 2009 11:41:02 GMT[\r][\n]
[\r][\n]
PROPFIND /grosti/Web/Sites/iWeb/Pm-it/ HTTP/1.1[\r][\n]
Authorization: Basic Z3Jvc3RpOmdyZ3JzdDE4ZXA=[\r][\n]
Content-Type: text/xml; charset=utf-8[\r][\n]
User-Agent: Cyberduck/3.1 (4448)[\r][\n]
Host: idisk.mac.com[\r][\n]
Content-Length: 207[\r][\n]
Depth: 1[\r][\n]
[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
Server: AppleIDiskServer-1D2305[\r][\n]
x-responding-server: sslng106[\r][\n]
X-dmUser: grosti[\r][\n]
Content-Type: text/xml;charset=utf-8[\r][\n]
Transfer-Encoding: chunked[\r][\n]
Date: Fri, 09 Jan 2009 11:41:03 GMT[\r][\n]
[\r][\n]
[\r][\n]
PROPFIND /grosti/Web/Sites/iWeb/Pm-it/download.html HTTP/1.1[\r][\n]
Authorization: Basic Z3Jvc3RpOmdyZ3JzdDE4ZXA=[\r][\n]
Content-Type: text/xml; charset=utf-8[\r][\n]
User-Agent: Cyberduck/3.1 (4448)[\r][\n]
Host: idisk.mac.com[\r][\n]
Content-Length: 207[\r][\n]
Depth: 0[\r][\n]
[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
Server: AppleIDiskServer-1D2305[\r][\n]
x-responding-server: sslng106[\r][\n]
X-dmUser: grosti[\r][\n]
Content-Type: text/xml;charset=utf-8[\r][\n]
Content-Length: 627[\r][\n]
Date: Fri, 09 Jan 2009 11:41:03 GMT[\r][\n]
[\r][\n]
PROPFIND /grosti/Web/Sites/iWeb/Pm-it/download.html HTTP/1.1[\r][\n]
Authorization: Basic Z3Jvc3RpOmdyZ3JzdDE4ZXA=[\r][\n]
Content-Type: text/xml; charset=utf-8[\r][\n]
User-Agent: Cyberduck/3.1 (4448)[\r][\n]
Host: idisk.mac.com[\r][\n]
Content-Length: 207[\r][\n]
Depth: 1[\r][\n]
[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
Server: AppleIDiskServer-1D2305[\r][\n]
x-responding-server: sslng106[\r][\n]
X-dmUser: grosti[\r][\n]
Content-Type: text/xml;charset=utf-8[\r][\n]
Transfer-Encoding: chunked[\r][\n]
Date: Fri, 09 Jan 2009 11:41:04 GMT[\r][\n]
[\r][\n]
[\r][\n]
PROPFIND /grosti/Web/Sites/iWeb/Pm-it/download.html HTTP/1.1[\r][\n]
Authorization: Basic Z3Jvc3RpOmdyZ3JzdDE4ZXA=[\r][\n]
Content-Type: text/xml; charset=utf-8[\r][\n]
User-Agent: Cyberduck/3.1 (4448)[\r][\n]
Host: idisk.mac.com[\r][\n]
Content-Length: 207[\r][\n]
Depth: 0[\r][\n]
[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
Server: AppleIDiskServer-1D2305[\r][\n]
x-responding-server: sslng106[\r][\n]
X-dmUser: grosti[\r][\n]
Content-Type: text/xml;charset=utf-8[\r][\n]
Content-Length: 627[\r][\n]
Date: Fri, 09 Jan 2009 11:41:04 GMT[\r][\n]
[\r][\n]
PROPFIND /grosti/Web/Sites/iWeb/Pm-it/download.html HTTP/1.1[\r][\n]
Authorization: Basic Z3Jvc3RpOmdyZ3JzdDE4ZXA=[\r][\n]
Content-Type: text/xml; charset=utf-8[\r][\n]
User-Agent: Cyberduck/3.1 (4448)[\r][\n]
Host: idisk.mac.com[\r][\n]
Content-Length: 207[\r][\n]
Depth: 1[\r][\n]
[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
Server: AppleIDiskServer-1D2305[\r][\n]
x-responding-server: sslng106[\r][\n]
X-dmUser: grosti[\r][\n]
Content-Type: text/xml;charset=utf-8[\r][\n]
Transfer-Encoding: chunked[\r][\n]
Date: Fri, 09 Jan 2009 11:41:04 GMT[\r][\n]
[\r][\n]
[\r][\n]
PUT /grosti/Web/Sites/iWeb/Pm-it/download.html HTTP/1.1[\r][\n]
Content-Type: text/html[\r][\n]
User-Agent: Cyberduck/3.1 (4448)[\r][\n]
Host: idisk.mac.com[\r][\n]
Expect: 100-continue[\r][\n]
Content-Length: 23453[\r][\n]
[\r][\n]
HTTP/1.1 100 Continue[\r][\n]
HTTP/1.1 100 Continue[\r][\n]
[\r][\n]
HTTP/1.1 401 Unauthorized[\r][\n]
HTTP/1.1 401 Unauthorized[\r][\n]
Server: AppleIDiskServer-1D2305[\r][\n]
x-responding-server: sslng106[\r][\n]
WWW-Authenticate: Basic realm="idisk.mac.com"[\r][\n]
WWW-Authenticate: Digest realm="idisk.mac.com", qop="auth", nonce="928d802faf5cb4791a18d7b11d9b5391", stale="false", opaque="6a5211231a775b90f8bb5a1383897820"[\r][\n]
Content-Length: 12[\r][\n]
Date: Fri, 09 Jan 2009 11:41:09 GMT[\r][\n]
[\r][\n]
PUT /grosti/Web/Sites/iWeb/Pm-it/download.html HTTP/1.1[\r][\n]
Content-Type: text/html[\r][\n]
User-Agent: Cyberduck/3.1 (4448)[\r][\n]
Expect: 100-continue[\r][\n]
Content-Length: 23453[\r][\n]
Authorization: Digest username="grosti", realm="idisk.mac.com", nonce="928d802faf5cb4791a18d7b11d9b5391", uri="/grosti/Web/Sites/iWeb/Pm-it/download.html", response="44b5f76e2374674845aa9c008bc680f2", qop=auth, nc=00000001, cnonce="d14a6232a38c1c0f959dbb9dd725d08c", opaque="6a5211231a775b90f8bb5a1383897820"[\r][\n]
Host: idisk.mac.com[\r][\n]
[\r][\n]
HTTP/1.1 100 Continue[\r][\n]
HTTP/1.1 100 Continue[\r][\n]
[\r][\n]


Change History (3)

comment:1 Changed on Jan 9, 2009 at 3:13:14 PM by dkocher

  • Description modified (diff)

comment:2 Changed on Jan 9, 2009 at 3:17:03 PM by dkocher

  • Milestone set to 3.1.1
  • Status changed from new to assigned
  • Summary changed from getting upload error with v. 3.1 to iDisk Upload Incompatibility

Actually a duplicate of #2858.

comment:3 Changed on Jan 9, 2009 at 4:17:15 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.