Cyberduck Mountain Duck CLI

#2911 closed defect (duplicate)

Download/Upload does not overwrite or results in 0kb files

Reported by: verviana Owned by: dkocher
Priority: normal Milestone: 3.2.1
Component: ftp Version: 3.1.1
Severity: major Keywords: overwrite, 0kb, download, upload
Cc: Architecture:
Platform:

Description

Ever since downloading the new version of Cyberduck, I've been having sporadic problems downloading/uploading.

Specifically, when I'm trying to overwrite a file (replace a file on my desktop with the newer file on the server, or vice versa) it only works properly about 50% of the time. I get a taskbar, it thinks for a few minutes and announces "download (or upload) complete" in my transfer window.

However, when I go to utilize the file, one of two things happens:

  1. it hasn't been overwritten. the old version of the file is still in place. this does not surprise me, because only about 50% of the time does Cyberduck pop up and ask me if I wish to overwrite, which it used to do consistently.
  2. It has been overwritten--with an empty, 0 kb file. Usually, on second or third attempt I get the complete file.

I've experienced this phenomenon on various computers using various methods of connecting to the internet, and it's consistent (in other words: the problem isn't me, as far as I can tell).

I did try to search through tickets to see if someone had reported something similar but didn't see anything... so I am sorry if this is a duplicate ticket. Are you guys aware of this problem/is there a fix for it forthcoming?

Change History (9)

comment:1 Changed on Feb 4, 2009 at 6:13:21 PM by verviana

Hey, anything getting done about this?

I've been dealing with this situation ongoingly (the new upgrade hasn't helped) but I have figured out more concisely what the pattern is.

  1. I download a file.
  2. If it is going to overwrite a file, it asks me to overwrite and I hit OK.
  3. A zero kb file is downloaded. It, obviously, won't open.
  4. I manually go and download it AGAIN, and this time it downloads the complete file.

I'm wondering if it may be a conflict with the latest Leopard update? I've noticed that this started happening around the same time I started getting those new Leopard "whoa hey you're opening something that was downloaded from the big bad internet!!!" warnings.

comment:2 Changed on Mar 26, 2009 at 7:11:05 PM by charles@…

I experience exactly the same problem using Mac OS X 10.4.11 (Tiger). The only way is to delete all your files on your server, and then ftp reupload all the files from your computer to the server using Cyberduck.

comment:3 Changed on Mar 26, 2009 at 7:24:48 PM by verviana

Huh.

I don't think that solution would really work for me because I manage like ten different websites. I'd be too afraid of somehow losing my clients' stuff or creating downtime for them.

But it is interesting (and weird) that that works. I wonder why? Thanks for replying...

comment:4 Changed on Apr 5, 2009 at 8:08:14 PM by dkocher

Please post the transcript from View → Log Drawer which might give us a clue what is going on. Also any related output in the system.log (/Applications/Utilities/Console.app).

comment:5 Changed on May 11, 2009 at 7:16:00 PM by mattyb

I am having the same problem after upgrading Cyberduck rather than the update of Leopoard. It seems to only happen when replacing a file on your computer. I sometimes have to re-download the file 3 times before it isn't 0kb anymore. There is nothing in the Log Drawer that says anything about the download. If anyone has found a fix for this please let me know.

comment:6 follow-up: Changed on May 27, 2009 at 9:21:53 AM by caplod

I am having the same problem like verviana . If I download the file for the second time it asks me to overwrite and I get the 0KB file. nothing in the Log Drawer but I get this in system.log:

May 27 11:15:19 theborg com.apple.quicklook[2833]:         /Users/test/Downloads/test.ods.zip, and cannot find /Users/test/Downloads/test.ods.ZIP, period.
May 27 11:15:29 theborg kernel[0]: IOHIDSystem::relativePointerEventGated: Capping VBL time to 20000000 (was 28841324)
May 27 11:15:29 theborg Cyberduck[2696]: Error writing quarantine attribute
May 27 11:15:30 theborg com.apple.quicklook[2833]:   End-of-central-directory signature not found.  Either this file is not
May 27 11:15:30 theborg com.apple.quicklook[2833]:   a zipfile, or it constitutes one disk of a multi-part archive.  In the
May 27 11:15:30 theborg com.apple.quicklook[2833]:   latter case the central directory and zipfile comment will be found on
May 27 11:15:30 theborg com.apple.quicklook[2833]:   the last disk(s) of this archive.
May 27 11:15:30 theborg com.apple.quicklook[2833]: unzip:  cannot find zipfile directory in one of /Users/test/Downloads/test.ods or
May 27 11:15:30 theborg com.apple.quicklook[2833]:         /Users/test/Downloads/test.ods.zip, and cannot find /Users/test/Downloads/test.ods.ZIP, period.

comment:7 in reply to: ↑ 6 Changed on May 27, 2009 at 11:52:28 AM by dkocher

Replying to caplod:

I am having the same problem like verviana . If I download the file for the second time it asks me to overwrite and I get the 0KB file. nothing in the Log Drawer but I get this in system.log:

May 27 11:15:19 theborg com.apple.quicklook[2833]:         /Users/test/Downloads/test.ods.zip, and cannot find /Users/test/Downloads/test.ods.ZIP, period.
May 27 11:15:29 theborg kernel[0]: IOHIDSystem::relativePointerEventGated: Capping VBL time to 20000000 (was 28841324)
May 27 11:15:29 theborg Cyberduck[2696]: Error writing quarantine attribute
May 27 11:15:30 theborg com.apple.quicklook[2833]:   End-of-central-directory signature not found.  Either this file is not
May 27 11:15:30 theborg com.apple.quicklook[2833]:   a zipfile, or it constitutes one disk of a multi-part archive.  In the
May 27 11:15:30 theborg com.apple.quicklook[2833]:   latter case the central directory and zipfile comment will be found on
May 27 11:15:30 theborg com.apple.quicklook[2833]:   the last disk(s) of this archive.
May 27 11:15:30 theborg com.apple.quicklook[2833]: unzip:  cannot find zipfile directory in one of /Users/test/Downloads/test.ods or
May 27 11:15:30 theborg com.apple.quicklook[2833]:         /Users/test/Downloads/test.ods.zip, and cannot find /Users/test/Downloads/test.ods.ZIP, period.

Can you try to disable the download quarantine feature as described in the wiki.

comment:8 Changed on May 28, 2009 at 11:32:40 AM by caplod

hmm, I disabled the quarantine feature. The error "Error writing quarantine attribute" disappeared. still I get 0KB files.

system.log:

May 28 13:28:00 theborg com.apple.quicklook[162]:   End-of-central-directory signature not found.  Either this file is not
May 28 13:28:00 theborg com.apple.quicklook[162]:   a zipfile, or it constitutes one disk of a multi-part archive.  In the
May 28 13:28:00 theborg com.apple.quicklook[162]:   latter case the central directory and zipfile comment will be found on
May 28 13:28:00 theborg com.apple.quicklook[162]:   the last disk(s) of this archive.
May 28 13:28:00 theborg com.apple.quicklook[162]: unzip:  cannot find zipfile directory in one of /Users/test/Downloads/test.ods or
May 28 13:28:00 theborg com.apple.quicklook[162]:         /Users/test/Downloads/test.ods.zip, and cannot find /Users/test/Downloads/test.ods.ZIP, period.

comment:9 Changed on Jun 26, 2009 at 3:06:16 PM by dkocher

  • Milestone set to 3.2.1
  • Resolution set to duplicate
  • Status changed from new to closed

In #3252.

Note: See TracTickets for help on using tickets.
swiss made software