Cyberduck Mountain Duck CLI

Opened 10 years ago

Closed 8 years ago

#2944 closed enhancement (fixed)

No transcript for SFTP/SCP connections

Reported by: bram.esposito@… Owned by: dkocher
Priority: normal Milestone: 4.0.2
Component: sftp Version: 3.1.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

When connecting to a SFTP host the Log Drawer remains empty.

I reproduced this on 5 servers.

I cannot remember if I ever saw it work in previous versions.

I could not find any existing tickets on this issue.

Change History (6)

comment:1 Changed 9 years ago by dkocher

  • Summary changed from SFTP (SCP over SSH) Log is not visisble in Log Drawer to No transcript for SFTP/SCP connections

comment:2 Changed 8 years ago by dkocher

  • Type changed from defect to enhancement

We never had a transcript for SFTP previously.

comment:3 Changed 8 years ago by dkocher

#5356 closed as duplicate.

comment:4 Changed 8 years ago by ADobkin

I would like to voice my opinion on this bug. I apologize in advance if this is not the most appropriate forum.

This may be arguing semantics, but setting the bug type as an enhancement rather than a defect is wrong in my opinion. This is not a "new feature", but rather unexpected/unintended/unintuitive behavior in its current form. When a user selects "Toggle Log Drawer" and does an SFTP/SCP transfer, and nothing appears there, they think something is wrong - and it is. At the very least, there should be a log entry that pops up there saying that logging is not yet available for SFTP/SCP, otherwise the user is kept completely in the dark about it. They shouldn't need to know in advance that the logging is dependent on which protocol they use to do the transfer.

In my situation, I use Cyberduck almost exclusively with SFTP/SCP now, so this is a critical issue for me. In particular, whenever I use the "synchronize" option, I need to be able to see a transcript of what files were transferred, since it could cause problems if files were overwritten, deleted, etc. without my knowledge. To synchronize a whole directory hierarchy with absolutely no indication of what occurred is playing with fire. It has become such a big issue for me that I had to switch to FileZilla instead until this bug is addressed.

I have a lot of respect for Cyberduck's interface, but this is clearly a bug that should be resolved by now, after being open for two years. I am anxious to see it completed by the 4.0 release.

comment:5 Changed 8 years ago by dkocher

  • Milestone set to 4.1
  • Status changed from new to assigned

comment:6 Changed 8 years ago by dkocher

  • Milestone changed from 4.1 to 4.0.2
  • Resolution set to fixed
  • Status changed from assigned to closed

In r8565.

Note: See TracTickets for help on using tickets.
swiss made software