Cyberduck Mountain Duck CLI

#2976 closed enhancement (wontfix)

Shell access in Command window

Reported by: macmedix Owned by: dkocher
Priority: low Milestone:
Component: interface Version: 3.1.1
Severity: minor Keywords: ssh command sftp
Cc: macmedix@… Architecture:
Platform:

Description

Hello, Thanks for CyberDuck. I really love it. I am mostly using it for SSH connections.

After connecting to my server via SSH, then uploading a shell script, I got info & added "execute" permissions for Owner (744). Then I clicked once on that script (cleanup.sh) and tried to execute it.

Pulled the Go menu to "Send Command..." and entered "./cleanup.sh" in the dialog box. The result was; bash: line 1: ./cleanup.sh: No such file or directory

So I entered it again without the ./ Result: bash: line 1: cleanup.sh: command not found

So I left CyberDuck, launched iTerm, opened a terminal window, logged in, cd to the correct directory and typed; ./cleanup.sh which did work ok. But I would have liked to stay in CyberDuck.

Can CyberDuck execute a script or application during a SSH session? I am loving CyberDuck as a ssh client, and my expectations are growing. Please fix this feature to work as expected, OR add support for executing a shell script when connected via SSH. Please also add "Execute" to the command-click menu and to the Go menu.

I am happy to pay again for CyberDuck, and I very much appreciate your effort. :-) Thanks!!!! Dave Nathanson

Change History (7)

comment:1 Changed on Feb 13, 2009 at 4:51:25 PM by dkocher

  • Component changed from core to interface
  • Milestone set to 3.1.3
  • Priority changed from normal to low
  • Severity changed from normal to minor
  • Status changed from new to assigned
  • Type changed from defect to enhancement

Either the current working directory must be the same as the script resides in (when executing ./cleanup.sh). If not cd to there first. Otherewise the path must be in your PATH environment variable to be excecuted globally.

As an enhancement the Send Command... invocation could change the working directory to the one opened in the browser itself.

comment:2 follow-up: Changed on Feb 13, 2009 at 6:20:55 PM by macmedix

interesting! As a followup, I used Cyberduck to "send command..." and entered "pwd" to learn that the path is not as expected! I'm using DreamHost.com, a major hosting company. When I login (ssh or FTP) I connect as my username, then cd into the correct dir for that webs erver. What I see as the root (/) is not what pwd sees as the root.

Where I think I am:
/domainname.com/

Where FTP connections say I am:
/domainname.com/

where Cyberduck says I am:
pwd
/home/.margara/macmedix

Where SSH says I am:
[refresco]$ pwd
/home/macmedix/domainname.com

Interesting that the same question has 3 different answers. To try & run the script from Cyberduck, I used the "Send Command..." to say:
pwd
/home/.margara/macmedix
cd domainname.com
pwd
/home/.margara/macmedix
cd ..
pwd
/home/.margara/macmedix

So it appears that Cyberduck is not able to cd .. nor cd into a directory from the "Send Command..." Perhaps this is a result of how this webhost does things, but I can easily use Terminal or iTerm and SSH into the same host to move around and run scripts. I also tried the same test on my own OSX server, and it seems to me that CyberDuck was not able to "Send Command..." to cd up or into any folder. I connected using CyberDuck via SSH as root and was stuck in the root's home folder.

If it helps, I'm happy to give you a shell account on the web host so you can see it yourself.

Thanks very much for your time and consideration! I really appreciate it! :-)

Dave

comment:3 in reply to: ↑ 2 Changed on Mar 18, 2009 at 11:19:40 AM by dkocher

  • Milestone 3.1.3 deleted
  • Summary changed from Send a Command (ssh) to Shell access in Command window

Replying to macmedix: The issue is that the Command window in Cyberduck does not open a proper shell; e.g. bash. Therefore you can not rely on built-in features of a shell environment such as cd.

comment:4 Changed on Apr 11, 2009 at 9:25:36 AM by dkocher

See also #3110.

comment:5 follow-up: Changed on Aug 13, 2009 at 5:30:32 AM by albertoz

Hi, & thanks for CyberDuck. How difficult will be to open proper shell window (with correct path, & login) instead of CyberDuck's Command Window?

comment:6 in reply to: ↑ 5 Changed on Aug 13, 2009 at 6:41:55 AM by dkocher

Replying to albertoz:

Hi, & thanks for CyberDuck. How difficult will be to open proper shell window (with correct path, & login) instead of CyberDuck's Command Window?

This is already implemented. See Open in Terminal.

comment:7 Changed on Jul 27, 2010 at 9:42:36 AM by dkocher

  • Resolution set to wontfix
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.