Cyberduck Mountain Duck CLI

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#3100 closed defect (fixed)

Synchronisation does not transfer files with equal size

Reported by: alfuken@… Owned by: dkocher
Priority: high Milestone: 3.3.1
Component: core Version: 3.1.2
Severity: major Keywords: synchronization
Cc: cwr Architecture:
Platform:

Description

I often have to synchronize local directory with ftp-server directory, and seems like Cyberduck doesn't handle this task as supposed to - it doesn't sync files, whose size in bytes has not been changed. Even if I change half of the file and size is remain the same - file is NOT being sync-d.

Steps to reproduce the problem:

  1. do some changes with local text file
  2. select "Synchronize..." in remote directory context menu
  3. select action "Upload"
  4. select local directory you wish to sync
  5. wait till it first synchronizes stuff as it should.
  6. Change one or few symbols local file, but make sure file size is _not_ changed after editing
  7. In Transfers window select recent "Synchronize" task and press green "Resume" button, to re-sync local directory with remote one, and press "Continue"
  8. After task is being done, Cyberduck shows in Transfers windows fllowing information: "Transfer incomplete. 0 of 0 B".
  9. As a result, local file has NOT being synchronized, though file has been changed.

Also, another bug is detected with this issue: after synchronization, either successful or not, Cyberduck shows message "Transfer incomplete", even if all files are sync-d successfully.

Attachments (1)

Cyberduck.png (118.0 KB) - added by mbeinhorn 9 years ago.
Documentation of error in synchronization of files (mbeinhorn)

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by gCD

i'm also suffering from this bug severely! debugging it would be most appreciated

Changed 9 years ago by mbeinhorn

Documentation of error in synchronization of files (mbeinhorn)

comment:2 Changed 9 years ago by mbeinhorn

I just uploaded a snapshot of this error, showing two files of the same size but with different time stamps. Synchronize does not identify them as different. Thank goodness I remembered changing the file today. Worse, the file size, while the same, is not that reported by Cyberduck (28.5KB). The files are actually 32KB (29,184 Bytes). There are actual differences in these two Excel files.

I am using Cyberduck Version 3.2 (4648) on my Intel MacBook running OS X, ver 10.5.6. I agree that this is extremely serious. If I want to go back to an earlier version of Cyberbuck, when did this error first creep in?

comment:3 Changed 9 years ago by cwr

  • Cc cwr added

Since this behavior is documented:

http://trac.cyberduck.ch/wiki/help/en/howto/sync#FilescanbesynchronizedbyselectingthedirectorytosynchronizeinthebrowserandselectFileSynchronize.

it is unclear if the author considers this a bug or a feature. I vote for "bug". I frequently want to synchronize files whose length have not changed. As a result I end up having to do the sync multiple times, going back and making a gratuitous change in length just to get sync to work.

http://forums.cocoaforge.com/viewtopic.php?f=9&t=20335

comment:4 Changed 9 years ago by bradsmith74

I can confirm that both the bug with not syncing files that are the same length and the "Transfer incomplete" bug are still in version 3.2.1.

comment:5 Changed 9 years ago by dkocher

  • Milestone set to 3.4
  • Status changed from new to assigned

Since we now support setting the timezone for a FTP bookmark and all other protocols have UTC dates, we should include a file for synchronization if the modification date is different.

comment:6 Changed 9 years ago by dkocher

#2523 closed as duplicate.

comment:7 Changed 9 years ago by jeroen.dierckx@…

I like the way WinSCP handles this (I often work on a windows machine at work). Because it is very difficult to compare files without downloading them all, WinSCP first does a thorough synchronization by downloading all files to the local directory (warning when modification dates are newer on the local side of course). From then, you can make it look for changes on the local files, and the changed files are uploaded automatically, thus automatically keeping the remote directory in sync.

All I have to do there is turning on the synchronization function and edit my files.

comment:8 Changed 9 years ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

As or r5605 we no more compare the file size but only the timestamp. Files with equal size are no more excluded by default.

comment:9 Changed 9 years ago by dkocher

  • Summary changed from Synchronize is not working properly. to Synchronisation does not transfer files with equal size

comment:10 Changed 8 years ago by arvidtp@…

Yeah! This change is MUCH appreciated!

Note: See TracTickets for help on using tickets.
swiss made software