Cyberduck Mountain Duck CLI

#3186 closed defect (fixed)

Local file gets deleted when download-overwrite fails because online source is not available

Reported by: Copprhead Owned by: dkocher
Priority: normal Milestone: 3.2.1
Component: core Version: 3.2
Severity: major Keywords:
Cc: Architecture:
Platform:

Description

Reproduction:

Log in to an FTP site. Upload a file from a local folder. Remove the remote file via other means (shell login at the server). Cyberduck naturally doesn't see this change without reloading. Now drag the remote file from Cyberduck window to the local folder in the finder. It will ask what you want to do because file exists. Choose overwrite. Local file then gets deleted but remote file cannot be downloaded because it doesn't exist on the server anymore.

Correct behaviour should be that the local file stays if the remote file cannot be downloaded, either by checking before deleting if the remote file really exists or by just renaming the local file and renaming it back if download fails.

Change History (2)

comment:1 Changed on May 12, 2009 at 8:29:31 AM by dkocher

  • Milestone set to 3.2.1
  • Status changed from new to assigned

comment:2 Changed on Jun 26, 2009 at 7:09:55 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r4870 for FTP, S3 and SFTP.

Note: See TracTickets for help on using tickets.
swiss made software