Cyberduck Mountain Duck CLI

#3206 closed defect (fixed)

Redirection fails for uploads

Reported by: norbert.wagner@… Owned by: dkocher
Priority: normal Milestone: 3.8
Component: webdav Version: 3.2
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

i make a webdav connection to a https-Server. Login is okay, Directory Reading, Download also. Upload (empty) Folders worked, but a Upload of Files sends the File and after this it gives me a Error Moved Temporarily (302).

HTTP/1.1 302 Found[\r][\n]
Date: Wed, 27 May 2009 15:47:06 GMT[\r][\n]
Server: Apache/2.2.3 (Debian) mod_ssl/2.2.3 OpenSSL/0.9.8c[\r][\n]
Location: https://nuernberg-messe.euregio-
service.de/alfresco/webdav/N%c3%bcrnbergMesse/Neugestaltung%20und%20Erweiterung%20Eingang%20Mitte/Architektur/Visualisierungen/20090424%20Lastenheft%20Datenverarbeitung%20PLL.pdf[\r][\n]
Content-Length: 394[\r][\n]
Content-Type: text/html; charset=iso-8859-1[\r][\n]
[\r][\n]

Up- and Download via Finder worked fine.

Change History (7)

comment:1 Changed on May 27, 2009 at 2:54:18 PM by dkocher

  • Component changed from core to webdav
  • Summary changed from WebDav write Errors to Redirection fails for uploads

Please post the full transcript from View → Log Drawer which includes the HTTP headers sent.

comment:2 Changed on May 27, 2009 at 3:47:51 PM by norbert.wagner@…

HTTP/1.1 302 Found[\r][\n]
Date: Wed, 27 May 2009 15:47:06 GMT[\r][\n]
Server: Apache/2.2.3 (Debian) mod_ssl/2.2.3 OpenSSL/0.9.8c[\r][\n]
Location: https://nuernberg-messe.euregio-service.de/alfresco/webdav/N%c3%bcrnbergMesse/Neugestaltung%20und%20Erweiterung%20Eingang%20Mitte/Architektur/Visualisierungen/20090424%20Lastenheft%20Datenverarbeitung%20PLL.pdf[\r][\n]
Content-Length: 394[\r][\n]
Content-Type: text/html; charset=iso-8859-1[\r][\n]
[\r][\n]

Last edited on Nov 20, 2010 at 1:01:30 PM by dkocher (previous) (diff)

comment:3 Changed on Nov 14, 2009 at 1:43:09 PM by dkocher

  • Description modified (diff)

comment:4 Changed on Apr 1, 2010 at 8:39:11 AM by dkocher

#4314 closed as duplicate.

comment:5 Changed on Nov 26, 2010 at 3:29:09 PM by dkocher

The reasoning here comes from RFC 2616 that states the user agent MUST NOT automatically redirect the request unless it can be confirmed by the user, since this might change the conditions under which the request was issued.

comment:6 Changed on Nov 26, 2010 at 4:15:33 PM by dkocher

  • Milestone set to 4.0
  • Resolution set to fixed
  • Status changed from new to closed

In r7788.

comment:7 Changed on Sep 18, 2013 at 10:28:53 AM by dkocher

Reverted. See now #6586.

Note: See TracTickets for help on using tickets.
swiss made software