Cyberduck Mountain Duck CLI

#3246 closed defect (worksforme)

Open Web URL

Reported by: gs@… Owned by: dkocher
Priority: normal Milestone:
Component: interface Version: 3.2
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

the command tries to show the file in the browser. What is does is to use the "Web URL" from the Bookmark settings and adds path of the file in the ftp server. But most of the time, there is an extra "public" or "httpdocs" folder in the ftp path. If I enter this as the base "Path:" it should leave it out of the wbe URL

Change History (4)

comment:1 Changed on Jun 15, 2009 at 9:06:51 PM by dkocher

  • Component changed from core to interface

What you describe is the expected behaviour. Can you give an example?

comment:2 follow-up: Changed on Jun 16, 2009 at 3:31:44 AM by Anthony

To add an example:

if your directory is public_html and all of your sites folders are within, then put this in Path: public_html/

The rule of thumb is, whatever directory or directories your site contents are in, list all of them out in Path

Since I'm here, let me clarify the heck out of this thing. Let's say you have hosting with DreamHost. This is the the structure they give you: home/"username"/"website_name"

Say my username is "joe" and my website is "example.com". In Path I would type this:

home/joe/example.com/

If this is confusing just keep asking. Someone will explain it simply enough eventually :)

comment:3 in reply to: ↑ 2 Changed on Jun 18, 2009 at 8:05:34 AM by dkocher

make sure the path you enter is an absolute path. E.g.

/home/joe/example.com/

Then it should work as expected.

Replying to Anthony:

To add an example:

if your directory is public_html and all of your sites folders are within, then put this in Path: public_html/

The rule of thumb is, whatever directory or directories your site contents are in, list all of them out in Path

Since I'm here, let me clarify the heck out of this thing. Let's say you have hosting with DreamHost. This is the the structure they give you: home/"username"/"website_name"

Say my username is "joe" and my website is "example.com". In Path I would type this:

home/joe/example.com/

If this is confusing just keep asking. Someone will explain it simply enough eventually :)

comment:4 Changed on Nov 9, 2009 at 9:35:18 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.