Cyberduck Mountain Duck CLI

#3275 closed defect (worksforme)

ClassFormatError: Truncated class file

Reported by: anonymous Owned by: dkocher
Priority: normal Milestone:
Component: core Version: 3.2
Severity: blocker Keywords: Browser, Failure to launch
Cc: anaisr64-int@… Architecture:
Platform:

Description

Since I upgraded my MacBook Air 1.6 Ghz to Mac OS 10.5.6 at the beginning of the year 2009 (although around the same time I also purchased a Time Capsule -- don't know if that could have anything to do with the problem), Cyberduck became totally unusable (Cyberduck worked fine before that). Since then, when I launch Cyberduck, the Duck Icon bounces for a while on the dock, the menu above changes to the Cyberduck menu, but no browser window opens. On the Cyberduck menu, most things work ("Transfers", "Activity", "New Download" windows DO open), EXCEPT the most important browser window, which simply is non-existent!

I have tried:

File>New Browser --- > Nothing happens Upgrading to latest version of Cyberduck (a couple of new versions have been released since my problem began) Downgrading to previous versions ( I have tried from version 2.7 to version 3.2)

Trashing the preference files (e.g. .plist) for Cyberduck. I have even tried doing this every time I changed versions and between launchs Repairing permissions on my macbook, cleaning caches, etc. Upgrading my Mac to 10.5.7 Restarting my MacBook in Safe Mode and clean installing Cyberduck in that mode.

Whatever I've done, the problem persists!

Doing an Internet search, I found another user with the same problem, on MacUpdate. That person wrote:

May 14 2008 FIZIK I had donated in the past but haven't used Cyberduck for a while. Gave 3.0 a try -- no browser window upon launch. Doesn't respond to New Browser either. In fact, does not draw any windows, e.g. in response to About Cyberduck. Downgraded to 2.8.4 -- same effect. And yes, I have trashed its Prefs file and its folder in App Support before each launch...

(Version 3.0)


I really liked Cyberduck, used it for a few months and was about to donate, when this problem occurred. Now I've been unable to use it all year long.

Change History (4)

comment:1 follow-up: Changed on Jun 27, 2009 at 11:09:12 AM by dkocher

Can you find any related output in the console.log (/Applications/Utilities/Console.app)?

comment:2 in reply to: ↑ 1 Changed on Jul 1, 2009 at 11:31:12 PM by anonymous

Replying to dkocher:

Can you find any related output in the console.log (/Applications/Utilities/Console.app)?

27/06/09 01:14:58 a.m. Cyberduck[875] java/lang/ClassFormatError: Truncated class file Stack Trace: java.lang.ClassFormatError: Truncated class file

at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:675) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124) at java.net.URLClassLoader.defineClass(URLClassLoader.java:260) at java.net.URLClassLoader.access$100(URLClassLoader.java:56) at java.net.URLClassLoader$1.run(URLClassLoader.java:195) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:188) at java.lang.ClassLoader.loadClass(ClassLoader.java:316) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:280) at java.lang.ClassLoader.loadClass(ClassLoader.java:251) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:374) at ch.cyberduck.ui.cocoa.CDMainController.newDocument(CDMainController.java:704) at ch.cyberduck.ui.cocoa.CDMainController.newDocument(CDMainController.java:682) at ch.cyberduck.ui.cocoa.CDMainController.applicationDidFinishLaunching(CDMainController.java:452)

There are other similar ones, but when I try to submit them, your system says it's spam, so I only included the first

comment:3 Changed on Oct 18, 2009 at 8:57:42 PM by dkocher

  • Summary changed from No browser window - Cyberduck unusable to ClassFormatError: Truncated class file

comment:4 Changed on Nov 3, 2009 at 9:03:39 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Download the 3.3 beta or the latest nightly build which hopefully fixes this issue for you.

Note: See TracTickets for help on using tickets.