Cyberduck Mountain Duck CLI

#332 closed defect (worksforme)

Problems with selected items

Reported by: info@… Owned by: dkocher
Priority: low Milestone: 2.7.3
Component: interface Version: 2.6.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Thank you for a very neat program that I have come to love. The last versions have some bugs though that didn't occur in earlier versions.

When a file is selected a number of errors occur:

  1. quick search doesn't work
  1. refresh listing leaves the selected items in their place overwriting other items if listing has changed (this is especially weird after moving files into a subfolder)

Change History (8)

comment:1 Changed on May 11, 2006 at 10:54:13 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Cannot reproduce. Please reopen with some more details if you still see the problems in the lastest build available at http://update.cyberduck.ch/nightly/

comment:2 Changed on Jul 25, 2006 at 12:36:19 PM by info@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I still encounter the same problems with Version 2.6.1 (2341). I have put together PDFs for demonstrating the two problems. The PDF files show the following:

http://www.klarmedia.de/download/Cyberduck-Quick_search.pdf

  1. When a file is selected before I type something in the quick search box the file listing does not change.
  1. When I then de-select the file its name disappears, the rest stays the same.

3.-6. When I click on a remaining file name it disappears, but its place seems to be "selected".

  1. I can even select an empty line if there had been a file name before doing the search.
  1. When I click somewhere in the listing where there had not been a file before the search everything is de-selected and seems to be as it should look.
  1. The same happens when the search should result in one or more files...
  1. ...I can then also make the files disappear by selecting them...
  1. ...but when I click on the first line the file name changes to what is the search result.

http://www.klarmedia.de/download/Cyberduck-Refresh.pdf

  1. I select several files.
  1. I move them into the sub-folder "_bearbeitet"
  1. After the listing automatically refreshes it looks like this.
  1. After de-selecting it looks fine.

5.-6. When you only delete one file everything is fine, but...

7.-9. ...when you delete several files it looks all messed up (some files are still shown in their old place, some files are now selected that weren't before, some empty spaces are selected, but at the top everything is as it should be).

As far as I can see the "selected" state always seems to be stuck with the place rather than with the object. Maybe the best idea would be to de-select all after the listing is refreshed. In my opinion it does not make sense that a different file is selected after a refresh just because it is in the place of the old selection.

I hope you can determine the error with the help of this. If you need any further tests on my side please feel free to contact me. We can also chat in German then. :-)

Regards, Alexander

comment:3 Changed on Sep 2, 2006 at 10:20:21 AM by dkocher

  • Version changed from 2.5.5 to 2.6.1

comment:4 Changed on Sep 2, 2006 at 11:00:27 AM by dkocher

  • Milestone set to 2.6.2
  • Status changed from reopened to new

comment:5 Changed on Sep 2, 2006 at 11:00:53 AM by dkocher

  • Priority changed from normal to low
  • Status changed from new to assigned

comment:6 Changed on Sep 7, 2006 at 9:57:08 AM by dkocher

  • Milestone 2.6.2 deleted

comment:7 Changed on Dec 11, 2006 at 1:50:57 PM by dkocher

Is this still an issue in 2.7 builds?

comment:8 Changed on May 19, 2007 at 11:54:54 AM by dkocher

  • Milestone set to 2.7.3
  • Resolution set to worksforme
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.
swiss made software