Cyberduck Mountain Duck CLI

#3332 closed defect (duplicate)

S3 Bug with no name folders

Reported by: jzumbrun@… Owned by: dkocher
Priority: high Milestone: 3.3
Component: s3 Version: 3.2.1
Severity: blocker Keywords: crash, no-name directory
Cc: Architecture:
Platform:

Description

Just wanted to let you know that cyberduck crashes when there is a directory without a name in a bucket on S3. Im on 10.5.6 (osx) and 3.2.1(cyberduck). At first i didnt know why it kept crashing then I used another S3 client, saw there was a directory without a name, deleted it then opened cyberduck, went to the parent directory of the no-name directory and everything was fine now in cyberduck (no crashing) since the no-name directory was gone.

Change History (3)

comment:1 follow-up: Changed on Jul 15, 2009 at 8:23:20 PM by dkocher

  • Milestone set to 3.3
  • Version changed from 3.2 to 3.2.1

What do you mean with a directory without a name?

comment:2 in reply to: ↑ 1 Changed on Jul 15, 2009 at 8:58:22 PM by dkocher

S3 allows you to create an object like s3.amazonaws.com/bucketname/5/images/{directory-without-a-name}/image.jpg

or s3.amazonaws.com/bucketname/5/imagesimage.jpg

I dont know why this should be possible with S3 but when cyberduck was crashing i used another S3 client and found in the images 'directory' 3 'directories' named: 15, 14, an one with no name.

After i deleted the no name 'directory' cyberduck stopped crashing.

Looks very similar like issue #2575.

comment:3 Changed on Aug 12, 2009 at 9:18:08 PM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

I assume a duplicate of #3347.

Note: See TracTickets for help on using tickets.
swiss made software