Cyberduck Mountain Duck CLI

#3368 closed defect (worksforme)

Sync of large directories fails randomly

Reported by: johannes@liermann.org Owned by: dkocher
Priority: high Milestone: 3.6
Component: sftp Version: 3.2.1
Severity: major Keywords:
Cc: Architecture:
Platform:

Description

When syncing large directories with many subfolders via SFTP scanning of the directories will eventually halt for no apparent reason. If syncing is repeated with a significantly smaller folder containing the same directory which initially caused the failure, the problem will not be reproduced. Therefore, the problem apparently is not related with certain subfolders or files but when a critical number of subfolders is reached.

The problem does not occur with version 3.2, while the issue is fully reproduced by nightly build 4990.

Change History (1)

comment:1 Changed on Aug 5, 2010 at 2:14:29 PM by dkocher

  • Component changed from core to sftp
  • Milestone set to 3.6
  • Resolution set to worksforme
  • Status changed from new to closed

Please try the latest snapshot build. Please reopen if you can still replicate this issue.

Note: See TracTickets for help on using tickets.