Cyberduck Mountain Duck CLI

#3404 closed defect (worksforme)

S3 synchronize fails with "Failed to sanitize XML document" error

Reported by: cpu@… Owned by: dkocher
Priority: high Milestone:
Component: s3 Version: 3.2.1
Severity: critical Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

When attempting to use Synchronize to upload new files to an S3 bucket, I am receiving this error:

Failed to sanitize XML document destined for handler class org.jets3t.service.impl.rest.XmlResponsesSaxParser$ListBucketHandler.

I don't have an illegal characters in the filenames or directory names.

This error is reproducible but I cannot determine the cause. I'm wondering if it is a memory related issue as I'm trying to sync ~3,500 files (~460Mb) of data.

Here is my upload filter pattern:

.*~\..*|\.DS_Store|\.svn|\.fla|CVS

Change History (2)

comment:1 Changed on Nov 8, 2009 at 8:58:07 PM by dkocher

  • Description modified (diff)

comment:2 Changed on Jan 16, 2010 at 7:35:35 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot replicate this in the current stable version. Please reopen if this is still an issue.

Note: See TracTickets for help on using tickets.
swiss made software