Cyberduck Mountain Duck CLI

#3650 closed defect (duplicate)

Version 3.3b1 (5167) Problem Reading File List

Reported by: stuff@… Owned by: dkocher
Priority: normal Milestone: 3.3
Component: core Version: Nightly Build
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Version pulldown did not have an entry for 3.3b1...

3.3b1 ran on my newly updated Snow Leopard Macbook Pro (yea!). Connected to our FTP site, selected a file to download and it downloaded to many. Not sure how you will debug this, but the scenario is this (filenames changed obviously):

FTP directory has 3 files (A.ZIP, B.ZIP and C.ZIP) and some directories (ALPHA, BETA, GAMMA). Picking A.ZIP downloaded fine. picking C.ZIP tried to download C.ZIP *twice* but also tried to download everything in the GAMMA subdirectory.

Only change between the first test (which worked) and the second (which downloaded too much) is that I SORTED BASED ON DATE. I thought that might be the trigger, but I restarted CyberDuck and got the same behavior downloaded the C.ZIP file without changing sorting (or anything else)...

Strange, but there you go...

Change History (3)

comment:1 Changed on Aug 30, 2009 at 3:59:20 PM by dkocher

  • Version changed from 3.2.1 to Nightly Build

comment:2 Changed on Aug 30, 2009 at 4:01:45 PM by dkocher

  • Milestone set to 3.3

Looks like #3646.

comment:3 Changed on Aug 31, 2009 at 9:11:10 PM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software