Cyberduck Mountain Duck CLI

#3691 closed defect (thirdparty)

Uploading Large Files Fails, FTP and WebDAV

Reported by: joseph@… Owned by: dkocher
Priority: normal Milestone:
Component: webdav Version: 3.2.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

I've been trying to use Cyberduck to upload documents via WebDAV to one of our servers. When coming across larger files, file in excess of 30MB seems to be the failing point. I've attached a text doc with more details on the error received.

The error message displayed is

I/O Error: Upload Failed
some path.... to the webdav location
404 Not Found Not Found

In the bottom part of the window is:

Host: myserver.com[\r][\n]
Cookie: $Version=0; JSESSIONID=23EA3D8808F3ABE2CBBD4B2140D18052.tomcat1; $Path=/[\r][\n]
Cookie: $Version=0; AmberUser=32.93574D5959130B7A3A091A24269AD63C21.-n86h218se1l8fzein3a0; $Path=/[\r][\n]
Expect: 100-continue[\r][\n]
Content-Length: 30863360[\r][\n]
Content-Type: application/x-tar[\r][\n]
[\r][\n]
HTTP/1.1 404 Not Found[\r][\n]
HTTP/1.1 404 Not Found[\r][\n]
Content-Type: text/html[\r][\n]
Server: Microsoft-IIS/7.0[\r][\n]
X-Powered-By: ASP.NET[\r][\n]
Date: Wed, 09 Sep 2009 20:21:19 GMT[\r][\n]
Content-Length: 1245[\r][\n]
[\r][\n]

Change History (3)

comment:1 follow-up: Changed on Sep 10, 2009 at 7:42:43 AM by dkocher

  • Component changed from core to webdav
  • Description modified (diff)

comment:2 Changed on Nov 13, 2009 at 10:42:47 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

Looks like a server issue to me.

comment:3 in reply to: ↑ 1 Changed on Nov 26, 2015 at 9:59:28 AM by moware

I have recently had exactly the same problem (file uploads smaller than 30MB work, others don't). As it turned out, the culprit was not Cyberduck, but the server: IIS 7 has an upload limit of 30 MB. Unfortunately, rather then returning a useful error message, IIS yields a 404.

This can be fixed by adding a web.config setting in the WebDAV root directory (see, e.g. http://www.webtrenches.com/post.cfm/iis7-file-upload-size-limits). Since your error message shows the exact same combination (IIS 7, 404 error), I suspect that this is also the root cause for your problem.

Note: See TracTickets for help on using tickets.
swiss made software