Cyberduck Mountain Duck CLI

Opened 12 years ago

Closed 11 years ago

#371 closed enhancement (fixed)

Bookmarks drawer doesn't remember its width on window respawn.

Reported by: anonymous Owned by: dkocher
Priority: normal Milestone: 2.8.2
Component: interface Version: 2.8
Severity: minor Keywords:
Cc: Architecture:
Platform:

Description

When I quit and relaunch Cyberduck, the bookmarks drawer doesn't remember whether it's visible/hidden. The same is true for the drawer's position (left/right edge of the browser window).

Change History (5)

comment:1 Changed 12 years ago by dkocher

  • Component changed from core to interface
  • Resolution set to worksforme
  • Status changed from new to closed
  • Type changed from defect to enhancement

Cannot reproduce; the visiblity should be remembered. The drawer is opened on the side of the window where it fits best (depending how much space there is to the border of the screen).

comment:2 Changed 12 years ago by mail@…

I just noticed: When I'm hiding the drawer via toolbar button, the drawer's visibility is indeed remembered. Sorry. Closing the drawer manually (i.e., dragging its edge, and that's what I had done) doesn't have the same result, though.

Re: "drawer is opened on the side of the window where it fits best": Cyberduck appears to prefer the left edge -- I had expected the drawer to stay on the right side once I had forced it to open there. But that's probably a deliberate design decision, so I won't argue ;-)

comment:3 Changed 11 years ago by edmechem

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Summary changed from Bookmarks drawer doesn't remember its state on relaunch. to Bookmarks drawer doesn't remember its width on window respawn.
  • Version changed from 2.5.5 to 2.8

Bookmarks drawer doesn't remember its *width* between window spawnings.

I don't know if this is due to the 'default' behavior of Mac OS X's drawer UI, but, it would be nice if CyberDuck did the work necessary to maintain some preference for Bookmarks drawer width -- as well as orientation (left edge / right edge) -- and then, whenever spawning a new window, implemented those prefs.

(Of course, an elegant seamless implementation would be best, but I'd prefer this behavior even if it 'looked ugly', i.e. screen flashes while cyberduck 'corrects after the fact' OS X's default behavior (prefer left edge, wherever fits, 'standard' width).)

comment:4 Changed 11 years ago by dkocher

  • Milestone set to 2.8.1
  • Severity changed from normal to minor
  • Status changed from reopened to new

comment:5 Changed 11 years ago by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r3307.

Note: See TracTickets for help on using tickets.
swiss made software