Cyberduck Mountain Duck CLI

#3756 closed defect (worksforme)

S3 read failure

Reported by: Jim Schwartz <reg@…> Owned by: dkocher
Priority: normal Milestone:
Component: s3 Version: 3.2.1
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.6

Description (last modified by dkocher)

I created a new S3 account and did a couple of test uploads and download with Cyberduck 3.2.1. It worked as expected.

Later, I uploaded a few folders and subfolders worth of data, maybe 1GB worth, to the account on Windows with CloudBerry Explorer. That worked and the listing on Cloudberry was as expected.

Then, I opened Cyberduck to upload data from the Mac. That's where the surprises begin. My bucket and it's contained directories are present. But when I try to open those directories, I get errors in the form of a Failures dialog:

Failures

The last action could not be completed due to the following errors:
S3 Error:
<s3 pathname displayed>
Request Error.. Not Found.

The transcript reads, in one particular case:

x-amz-request-id: 82...<rest of id removed for security>[\r][\n]
x-amz-id-2: eQV<rest of id removed for security>[\r][\n]
Content-Type: application/xml[\r][\n]
Transfer-Encoding: chunked[\r][\n]
Date: Sun, 27 Sep 2009 19:05:00 GMT[\r][\n]
Server: AmazonS3[\r][\n]
[\r][\n]

If I then use CloudBerry on Windows or S3Hub on the Mac, I'm able to view the bucket and its contents as expected. Restarting Cyberduck doesn't change anything.

Change History (3)

comment:1 Changed on Sep 27, 2009 at 7:14:48 PM by dkocher

  • Description modified (diff)

comment:2 Changed on Apr 1, 2010 at 8:46:22 AM by dkocher

Is this still an issue with the current release? We would need to dig in further then.

comment:3 Changed on May 20, 2010 at 2:22:41 AM by dkocher

  • Platform set to Mac OS X 10.6
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software