Cyberduck Mountain Duck CLI

#3907 closed defect (wontfix)

Does not check the OS version before installing

Reported by: steveo@… Owned by: dkocher
Priority: highest Milestone:
Component: website Version: 3.3
Severity: blocker Keywords: installer os validation
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Version 3.3 installer does NOT check the OS version before installing, killing your 10.4.11 OS install

running 10.4.11 because my machine is trapped there... don't ask

ran the updater as usual, ran... ok

tried to start CD and it complains the OS is too old....well the installer should of checked before installing and killing my running copy. installer should OS detect and see if its safe to proceed. now I have to try to find my older installer

Change History (7)

comment:1 Changed on Nov 15, 2009 at 10:53:22 AM by dkocher

  • Component changed from ftp to core
  • Description modified (diff)
  • Summary changed from Version 3.3 installer does NOT check the OS version before installing, killing your 10.4.11 OS install to Does not check the OS version before installing

comment:2 Changed on Nov 15, 2009 at 10:53:48 AM by dkocher

You can find previous versions at http://cyberduck.ch/changelog/.

comment:3 Changed on Nov 15, 2009 at 2:21:11 PM by dkocher

  • Component changed from core to website

The software update feed should be fixed now and running Cyberduck on 10.4 should not advertise only 3.2.1 as the last compatible release.

comment:4 Changed on Nov 15, 2009 at 2:23:24 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

In r5560.

comment:5 Changed on Nov 30, 2009 at 10:46:09 PM by dkocher

  • Resolution fixed deleted
  • Status changed from closed to reopened

We had to remove the compatibility information from the feed because the minimum system requirement in the Sparkle feed crashes some earlier versions of Cyberduck when doing the update check.

comment:6 Changed on Dec 20, 2009 at 1:30:07 PM by molteni.laura@…

Thanks for the advice, I had the same problem since I run Mac OS 10.4. Would only warning that the link you gave to download the older Cyberduck versions, the page doesn't work well with Firefox 3.0.8 (the download "button" is not displayed, the page seems cut in the letf area). The link should be opened with Safari.

comment:7 Changed on Nov 25, 2010 at 8:22:46 PM by dkocher

  • Resolution set to wontfix
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software