Cyberduck Mountain Duck CLI

Opened 9 years ago

Closed 8 years ago

#3941 closed defect (fixed)

Hangs on quit with stale session

Reported by: mike.kristopeit@… Owned by: dkocher
Priority: high Milestone: 3.6
Component: sftp Version: 3.3
Severity: major Keywords:
Cc: Architecture:
Platform:

Description

i connect using sftp, and edit directly in textmate. quite often my sessions go stale, and saving/uploading fails, but if i hit stop and save again, cyberduck will reconnect and both saves will succeed.

i'm guessing what is happening is that the session has gone stale and cyberduck is trying to end the stale session, but it isnt responding.

a fix would be to find a way to keep the sessions from going stale... maybe with NOOP commands.

i am on a laptop connecting wirelessly, so maybe there is an interruption in signal and that is causing the sessions to break.

i fully plan on donating once this is addressed, because this is my only problem with the program, but for now it's a major one as cyberduck often hangs my machine during restarts...

Change History (5)

comment:1 Changed 9 years ago by dkocher

  • Summary changed from hangs on quit... requiring force quit to Hangs on quit with stale session

comment:2 Changed 9 years ago by anonymous

might be 2 separate tickets... 1) saves fail when the sessions are stale 2) program hangs on quit when the sessions are stale

so if you can stop them from stalling out, that fixes both, otherwise, just put code to timeout after 1 second and try to reconnect as if the user clicked the stop icon and then ran the save process in textmate again.

a hacky fix would be to delete the file "cyberduck_deleteme" then create it again, then delete it again. that should ensure a change is made. another setting for that defaulting to 10 minutes would be nice.

in a perfect world you stop the sessions from going stale, or provide options to force activity, and also add checks in the save routine and the quit routine to fix stale sessions.

comment:3 Changed 9 years ago by mike.kristopeit@…

the problem is still in the latest version... still waiting on this fixed. it's very easy for data to be lost if the session is stale and you think you saved a file you were working on, but it was never uploaded to the server.

if i hit the "stop sign" icon, and then go back into my editor and save again, then cyberduck will reconnect. it seems simple to me to detect a disconnect and automate those steps.

comment:4 Changed 9 years ago by yla

  • Component changed from sftp to core

refer to #4214 for 1)

comment:5 Changed 8 years ago by dkocher

  • Component changed from core to sftp
  • Milestone set to 3.6
  • Resolution set to fixed
  • Status changed from new to closed

In r6464. See also #5073.

Note: See TracTickets for help on using tickets.
swiss made software