Cyberduck Mountain Duck CLI

Opened 9 years ago

Closed 8 years ago

#3949 closed defect (fixed)

Unresponsive Interface

Reported by: jeremy@… Owned by: dkocher
Priority: normal Milestone: 3.8
Component: interface Version: 3.3
Severity: normal Keywords: transfer, transfers, list
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

I have version 3.3 and am running 10.5.8 on an intel Mac Pro.

Ever since upgrading to 3.3 Cyberduck is not as responsive. Specifically, when I drag a file from the window into a folder on the Finder the icon gets "stuck" with the green plus arrow and Cyberduck hangs for a few seconds before anything happens. Also, on launch I typically get the spinning beach ball as it "thinks" and I suppose tries to connect. And when downloading the download window gets graphic gets stuck as if it is still downloading when in fact it is finished. When the window is clicked it switches to the "finished" state.

The version before did not have these problems.

Thanks, I do love the program.

Change History (16)

comment:1 Changed 9 years ago by info@…

As with Jeremy, the user above, Cyberduck 3.3 on my Intel Mac Pro running 10.5.8 is generally less responsive and hangs for an especially long time on drag and drop file transfers. The previous version did not have any of these problems.

I also agree that Cyberduck is a fantastic program, and I really appreciate the time that everyone has put into making this the best file transfer application for the Mac.

comment:2 Changed 9 years ago by dkocher

  • Summary changed from program unresponsive to Unresponsive Interface

comment:3 Changed 9 years ago by locom

Hello I have the same problems as Jeremy and info@... . I tested Cyberduck on :

  • my Macbook black Intel CORE2DUO with 4Go of RAM and GMA X1300 with SnowLeopard installed
  • my MacMini CORE2DUO with 4Go of RAM and NVIDIA 9400M with Leopard (not snow)

On these two configurations, I have the same problem.

When this problem will be fixed ?

comment:4 Changed 9 years ago by tlarvenz@…

Same problem here, with a Power Mac Dual 2.3 running Leaopard 10.5.8

comment:5 Changed 9 years ago by crohweder@…

Hello,

same problems here. Additionaly after starting Cyberduck the first click on the Quick Connect-list only shows the first listentry. After closing the list and reopen Cyberduck shows all entrys.

I love Cyberduck but it would be nice to fix this issues -)

comment:6 Changed 9 years ago by masselyn@…

Same thing here, I was wondering whether it was because I upgraded to 10.6 recently on my Macbook Pro. It is very hard to work, and as a developer I transfer files all the time, but it hangs for such a long time either up/download or I get a transfer incomplete a lot. If everyone thinks this is the new version - heck I will install the old one back again.

comment:7 Changed 9 years ago by max.cybele@…

I had the same exact problem. I think I got a solution. Go to the preferences, click on the Transfers tab. The general "sub tab" should be highlighted. Ther is a Transfer files pull down menu. Click on that and select "Use Browser connection".

Don't ask me why this setting has apparently changed with the 3.3 version but I no longer have any lag, just like before.

Hope it helps. Cheers. Max

comment:8 Changed 9 years ago by crohweder@…

Max, but with this setting you don't have control of the transfer via the filetransfer window. I ever used the default setting in the past which is "Neue Verbindung öffnen" (might be "use new connection" in the english Version).

But for some users it might be an proper work around to use the browser connection.

Kind regards Christian

comment:9 follow-up: Changed 9 years ago by max.cybele@…

Christian I agree but it sure beats waiting around for 15-20 seconds before the transfer initiates...it works for me until it gets resolved.

Cheers, Max

comment:10 in reply to: ↑ 9 ; follow-up: Changed 9 years ago by dkocher

Replying to max.cybele@…:

Christian I agree but it sure beats waiting around for 15-20 seconds before the transfer initiates...it works for me until it gets resolved.

Cheers, Max

Please clear the list of transfers in the transfer window which should speed things up.

comment:11 Changed 9 years ago by Yvon Letourneau <yvon_letourneau@…>

File listing window lags when scrolling. Not an issue for the Transfers window, though. It's as if the file listing window's redraws are delayed (unaccelerated?) with or without items in the transfer window. Using 3.4.1 (7580) on OS X 10.6.2 Intel 27" Core2Duo 4GB here. Don't know if this happens on OS X 10.5 @ PowerPC but I'll know soon enough. Anybody else experiencing this? I don't see a scrolling option to set. Is there a fix on the way for this? A workaround in the meantime would be great, seeing as this is the window i use the most.

comment:12 in reply to: ↑ 10 Changed 9 years ago by Another Jeremy

I am on a Macbook, 2.16 GHz Intel Core 2 Duo, 2GB RAM. After clearing the transfers window, I am no longer experiencing lag when dragging files to the browser window. It was so slow every time I dragged a file over; I almost switched to Fetch, despite donating to Cyberduck and having used it for years. I am very happy this is resolved (and now I'll try to remember to clear out that window every so often).

Replying to dkocher:

Replying to max.cybele@…:

Christian I agree but it sure beats waiting around for 15-20 seconds before the transfer initiates...it works for me until it gets resolved.

Cheers, Max

Please clear the list of transfers in the transfer window which should speed things up.

comment:13 follow-up: Changed 8 years ago by datapharmer@…

  • Architecture set to Intel
  • Keywords transfer transfers list added
  • Platform set to Mac OS X 10.6

I also discovered that the transfers list was slowing down everything on my computer when cyberduck was open. I actually started looking for an alternative to cyberduck because it had gotten so bad! Perhaps there is a memory management issue with the transfer list? At the least could we get a cleanup option or a warning when the list is getting big enough to impact performance?

comment:14 Changed 8 years ago by https://www.google.com/accounts/o8/id?id=aitoawnvwnpdllwtctqpcf__cdnqwxuba3r6qxe

I removed browser.view = 0 from my ch.sudo.cyberduck.plist and the unresponsiveness (as if the UI thread was constantly blocking on something and only released every other second or so) went away.

Hopefully this helps.

comment:15 in reply to: ↑ 13 Changed 8 years ago by dkocher

Replying to datapharmer@…:

I also discovered that the transfers list was slowing down everything on my computer when cyberduck was open. I actually started looking for an alternative to cyberduck because it had gotten so bad! Perhaps there is a memory management issue with the transfer list? At the least could we get a cleanup option or a warning when the list is getting big enough to impact performance?

This is a duplicate of #2889.

comment:16 Changed 8 years ago by dkocher

  • Milestone set to 4.0
  • Resolution set to fixed
  • Status changed from new to closed

Should be resolved as of r7637. Please reopen if still an issue in the latest nightly build.

Note: See TracTickets for help on using tickets.
swiss made software