Cyberduck Mountain Duck CLI

#4012 closed enhancement (fixed)

Web URL configuration fails for relative default path

Reported by: matthewlein@… Owned by: dkocher
Priority: normal Milestone: 3.8
Component: core Version: 3.3
Severity: normal Keywords: Open Web URL, Copy URL
Cc: Architecture:
Platform:

Description

I love cyberduck, but one thing always bothers me a bit. Its the Copy URL and Open Web URL. Somtimes I will upload somefile.html and want to see it. So I right click and choose Open Web URL. The problem is that it uses folder Path as part of the URL, not just the root. I think most people have to use www, public_html, html, or some kind of Path in their login, but they would rarely or never want that to be included in the Open Web URL or Copy URL path. Maybe a preference could be created to ignore that Path. Then I would get

matthewlein.com/somefile.html

instead of

matthewlein.com/html/somefile.html

Change History (11)

comment:1 Changed on Dec 25, 2009 at 11:46:51 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Set /html as the default path in the bookmark. It will then be removed from the Web URL copied.

comment:3 Changed on Dec 25, 2009 at 11:48:37 AM by dkocher

  • Summary changed from Feature request to Web URL configuration

comment:4 follow-up: Changed on Sep 6, 2010 at 8:27:14 PM by danaris

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I can confirm that this does not work as desired.

I have an SFTP bookmark with the default path set to public_html/images/ and the web URL set to http://server.tld/~danaris/images. I connect this bookmark, select one of my files, and copy its HTTP URL, and it comes out as http://server.tld/~danaris/images/home/danaris/public_html/images/image.jpg.

comment:5 in reply to: ↑ 4 Changed on Sep 7, 2010 at 8:13:48 AM by dkocher

  • Milestone set to 4.0

Replying to danaris:

I can confirm that this does not work as desired.

I have an SFTP bookmark with the default path set to public_html/images/ and the web URL set to http://server.tld/~danaris/images. I connect this bookmark, select one of my files, and copy its HTTP URL, and it comes out as http://server.tld/~danaris/images/home/danaris/public_html/images/image.jpg.

Try to set the default path to an absolute value of /public_html/images (prepending /).

comment:6 Changed on Sep 10, 2010 at 8:23:25 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:7 Changed on Sep 10, 2010 at 8:26:53 PM by danaris

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I do not mean to give offense, dkocher, but no, it does not work. There is a workaround, but this is not the same thing at all.

There is no reason why "copy HTTP URL" should break so ridiculously just because I have a relative path set as my default path, rather than an absolute path.

comment:8 Changed on Sep 14, 2010 at 5:26:15 PM by dkocher

  • Milestone changed from 4.0 to 4.1
  • Summary changed from Web URL configuration to Web URL configuration fails for relative default path

comment:9 Changed on Nov 14, 2010 at 9:56:18 AM by dkocher

  • Component changed from interface to core
  • Milestone changed from 4.1 to 4.0

comment:10 Changed on Nov 15, 2010 at 11:24:26 AM by dkocher

Testcase in r7586.

comment:11 Changed on Nov 15, 2010 at 2:41:45 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r7588.

Note: See TracTickets for help on using tickets.
swiss made software