Cyberduck Mountain Duck CLI

#4017 closed enhancement (worksforme)

View files in column view

Reported by: macmladen@… Owned by: dkocher
Priority: normal Milestone:
Component: interface Version: 3.3
Severity: normal Keywords:
Cc: mladen@… Architecture:
Platform:

Description

It is strange to me that nearly all ftp programs, even including some commercial are not using default Apple handler (control) of the list of files.

My suggestion is that user should be enabled to use views that are available in finder, to use standard Apple interface control and possibly inherit some useful things like services, drag & drop, copy & paste..

And also to offer services for Finder.

Change History (9)

comment:1 Changed on Dec 19, 2009 at 12:11:13 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

The column view feature request is a duplicate of #6. The other feature requsts like drag & drop or copy & paste should work as you would expect.

comment:2 follow-ups: Changed on Dec 19, 2009 at 12:36:58 PM by MacMladen <macmladen@…>

Well.. I could join #6 but this is different.

It is not only the question of implementing column view, it is question of using standard Apple list box (or however it is called).

Inheriting would allow that when you drag something to folder and hover, it would spring open. This is not happening now.

Also, copy in finder and paste in Cyberduck is also not working. It is either not working inside Cyberduck (copy in one folder, open another, paste). They are working somehow, but that is not like in Finder and is not intuitive. If you cut a file (as object) and paste it, Cyberduck first say that it already exist which is not true and when I accept to overwrite it says It does not exist and delete original file.

Cut, copy and paste should work as expected and in context of selection. If copy is made on same place, offer rename like finder, it is useful for having quick backup of original file while working.

So this is kind of a bug + enhancement

comment:3 in reply to: ↑ 2 Changed on Dec 19, 2009 at 2:11:26 PM by dkocher

Replying to MacMladen <macmladen@…>:

It is not only the question of implementing column view, it is question of using standard Apple list box (or however it is called).

Use View → Customize Toolbar to drag the View widget to the toolbar to switch between list and outline view.

comment:4 in reply to: ↑ 2 Changed on Dec 19, 2009 at 2:12:26 PM by dkocher

Replying to MacMladen <macmladen@…>:

Inheriting would allow that when you drag something to folder and hover, it would spring open. This is not happening now.

Choose Preferences → Browser → Use spring-loaded folders when dragging files to enable.

comment:5 in reply to: ↑ 2 Changed on Dec 19, 2009 at 2:24:29 PM by dkocher

Replying to MacMladen <macmladen@…>:

Also, copy in finder and paste in Cyberduck is also not working. It is either not working inside Cyberduck (copy in one folder, open another, paste). They are working somehow, but that is not like in Finder and is not intuitive. If you cut a file (as object) and paste it, Cyberduck first say that it already exist which is not true and when I accept to overwrite it says It does not exist and delete original file.

Cut, copy and paste should work as expected and in context of selection. If copy is made on same place, offer rename like finder, it is useful for having quick backup of original file while working.

You can cust and paste files using Command-X and Command-V. When pasting the file, make sure the working directory (selected in the popup button above the directory listing) is different.

comment:6 follow-ups: Changed on Dec 19, 2009 at 11:19:18 PM by MacMladen <macmladen@…>

So, here where we are :)

Changing View is OK for me (I'm no light user ;) but I didn't see spring-loaded folders which is very nice (should be on by default). But.. still, there are some issues that should be solved.

I am not sure if Cyberduck were using standard Apple would solve interface and user experience issues, but here is what I think:

  • cut, copy and paste should work in context, that is if files are selected work on them which should also be the case for files copied from Finder, no need to have another command. Copy URL is needed.
  • cut, copy and paste should not work by coping over to my machine and uploading back. If we are on SFTP/SSH then use ssh for commands like cut, copy and paste (issuing cp or mv commands. Did I say how useful (read powerful) would be regex select / deselect / invert selection? Use shell commands for enhancements whenever possible!
  • bug: you did not read well what I wrote: when I copy and paste in same location, Cyberduck erase file if I say overwrite. Ever if I did say overwrite over same exact file then don't do anything! But because of universal philosophy that works for all protocols of upload/download you leave user without a file. Prevent that and offer or just make a coy like finder by adding ++ number. We are Mac folks, aren't we? I use it all the time to make quick backup copy while saving new version.
  • click and after some time click bring rename in Finder. Not in Cyberduck. That is also one thing I expect in inheriting standard Apple folder view.

I hope this helps in improving Cyberduck. RBrowser is fine piece of software but is not done quite in Mac fashion. However it is brilliant for SFTP, have support column and really is using ssh and commands (cp, mv, bzip, gzip, tar.gz, etc).

I strongly believe that these things could push Cyberduck in front of every other FTP/SFTP software, commerial or not. RBrowser is reserving those SSH options for paid version only.

comment:7 in reply to: ↑ 6 Changed on Dec 20, 2009 at 12:31:50 AM by dkocher

Replying to MacMladen <macmladen@…>:

So, here where we are :)

Changing View is OK for me (I'm no light user ;) but I didn't see spring-loaded folders which is very nice (should be on by default). But.. still, there are some issues that should be solved.

I am not sure if Cyberduck were using standard Apple would solve interface and user experience issues, but here is what I think:

  • cut, copy and paste should work in context, that is if files are selected work on them which should also be the case for files copied from Finder, no need to have another command. Copy URL is needed.
  • cut, copy and paste should not work by coping over to my machine and uploading back. If we are on SFTP/SSH then use ssh for commands like cut, copy and paste (issuing cp or mv commands. Did I say how useful (read powerful) would be regex select / deselect / invert selection? Use shell commands for enhancements whenever possible!
  • bug: you did not read well what I wrote: when I copy and paste in same location, Cyberduck erase file if I say overwrite. Ever if I did say overwrite over same exact file then don't do anything! But because of universal philosophy that works for all protocols of upload/download you leave user without a file. Prevent that and offer or just make a coy like finder by adding ++ number. We are Mac folks, aren't we? I use it all the time to make quick backup copy while saving new version.
  • click and after some time click bring rename in Finder. Not in Cyberduck. That is also one thing I expect in inheriting standard Apple folder view.

I hope this helps in improving Cyberduck. RBrowser is fine piece of software but is not done quite in Mac fashion. However it is brilliant for SFTP, have support column and really is using ssh and commands (cp, mv, bzip, gzip, tar.gz, etc).

I strongly believe that these things could push Cyberduck in front of every other FTP/SFTP software, commerial or not. RBrowser is reserving those SSH options for paid version only.

Thanks for the detailed report!

comment:8 in reply to: ↑ 6 Changed on Dec 20, 2009 at 12:32:57 AM by dkocher

Replying to MacMladen <macmladen@…>:

However it is brilliant for SFTP, have support column and really is using ssh and commands (cp, mv, bzip, gzip, tar.gz, etc).

We do have support to create and expand archives?

comment:9 Changed on Dec 20, 2009 at 7:27:07 AM by MacMladen <macmladen@…>

I know you have archive/expand but what if I have folder with 10.000 files, some 500MB+ in size I want to move to another location on server?

Using ssh commands it is as fast as read new folder content. Download/upload strategy does not work there. There are also some other commands that could be nicely integrated, but first of all copy and move.

Supporting regex for selection in toolbar would be huge boost for powerusers.

I hope those 2 enhancements will find the way to Cyberduck along with column.

Note: See TracTickets for help on using tickets.
swiss made software