Cyberduck Mountain Duck CLI

#4084 closed defect (worksforme)

Resume fails for upload

Reported by: umiwangu@… Owned by: dkocher
Priority: normal Milestone:
Component: ftp Version: 3.3
Severity: normal Keywords:
Cc: umiwangu@… Architecture:
Platform: Mac OS X 10.6

Description (last modified by dkocher)

I looked through the previous tickets, but I couldn't find anything directly related to this. I'm also not sure if this is a server side issue or something to do with CyberDuck.

I'm trying to upload new files to my server (ftp.bic-church.org) for development, so I'm uploading the same file every couple minutes. Sometimes the file transfer works, sometimes it gives the following error:

I/O Error: Upload Failed
/httpdocs/wm/get-involved/partnership2/botswana/partnership-handbook-v3.asp
Skipped 25159 bytes instead of 29977.

The transcript shows the following:

PASV
227 Entering Passive Mode (65,61,47,111,8,190).
APPE partnership-handbook-v3.asp
125 Data connection already open; Transfer starting.
QUIT
226 Transfer complete.

Now, if I delete the file on the server, and then try the transfer, it works fine.

This is quite annoying, to have to keep deleting the files on the server and then uploading.

I've been using CyberDuck for about a week, and it seemed to be fine, until now.

Change History (12)

comment:1 Changed on Jan 16, 2010 at 1:43:01 PM by dkocher

  • Component changed from core to ftp
  • Description modified (diff)
  • Summary changed from Upload errors - overwriting issues? to Resume fails for upload

comment:2 Changed on Jan 16, 2010 at 7:25:04 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

In r5759.

comment:3 Changed on Jan 18, 2010 at 2:21:53 PM by umiwangu@…

My apologies... I'm not that familiar with bug reporting. Does this mean that the issue has been fixed in build r5759? If so, where can I download it?

comment:4 Changed on Jan 18, 2010 at 6:38:20 PM by dkocher

  • Milestone set to 3.4.1

comment:5 Changed on Jan 18, 2010 at 6:42:18 PM by umiwangu@…

Got it. Thanks! I'll see if it fixes the issue (seems to, so far).

comment:6 follow-up: Changed on Jan 18, 2010 at 9:35:03 PM by umiwangu

The problem isn't any better now. In fact, it's a lot worse with this new build. Now any overwrites I do (from local computer to online server) don't take. The changes I make locally are not reflected online unless I manually delete the file online, and then replace it with the local copy.

comment:7 Changed on Jan 18, 2010 at 9:35:35 PM by umiwangu@…

Why don't I have permission to open this ticket again?

Shall I just make a new one?

comment:8 Changed on Jan 18, 2010 at 10:58:50 PM by dkocher

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:9 Changed on Jan 18, 2010 at 10:59:04 PM by dkocher

  • Milestone changed from 3.4.1 to 3.5

comment:10 in reply to: ↑ 6 ; follow-up: Changed on Apr 1, 2010 at 3:50:11 PM by dkocher

  • Platform set to Mac OS X 10.6

Replying to umiwangu:

The problem isn't any better now. In fact, it's a lot worse with this new build. Now any overwrites I do (from local computer to online server) don't take. The changes I make locally are not reflected online unless I manually delete the file online, and then replace it with the local copy.

Can you post the error message and full transcript log.

comment:11 in reply to: ↑ 10 Changed on Apr 2, 2010 at 5:46:21 AM by umiwangu@…

Replying to dkocher:

Replying to umiwangu:

The problem isn't any better now. In fact, it's a lot worse with this new build. Now any overwrites I do (from local computer to online server) don't take. The changes I make locally are not reflected online unless I manually delete the file online, and then replace it with the local copy.

Can you post the error message and full transcript log.

It's actually working well now. I think it may have been because "resume" was the default mode selected, when I actually wanted to use "overwrite". I think you can just close this ticket for now.

comment:12 Changed on Apr 2, 2010 at 6:13:08 AM by dkocher

  • Milestone 3.5 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software