Cyberduck Mountain Duck CLI

#4093 closed defect (worksforme)

Creating directory fails with SSH_FX_FAILURE

Reported by: yedel@… Owned by: dkocher
Priority: normal Milestone: 3.7
Component: sftp Version: 3.3
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.6

Description (last modified by dkocher)

I get frequently (but not always) errors when I try to synchronise large directories (>1GB). The error message is :

No such file (SSH_FX_NO_SUCH....

If I try to redo the transfer It often transfers more than 100%.

I have to use a tunnelled ssh connection established with:

ssh -p2234 -L 10101:remotehost:22 username@tunnelinghost

I have attached an screenshot with an >100% transfer where such an error occurred.

Attachments (3)

Cyberduck_error.tiff (128.0 KB) - added by yedel@… on Jan 15, 2010 at 6:15:50 PM.
Error screenshot
ErrorCDnew.tiff (219.8 KB) - added by yedel@… on Apr 1, 2010 at 5:49:58 PM.
Error message as of 1.4.2010
2000.zip (1.8 KB) - added by ye on Aug 8, 2010 at 6:07:54 AM.
Ziped folder with contend to produce the error

Download all attachments as: .zip

Change History (22)

Changed on Jan 15, 2010 at 6:15:50 PM by yedel@…

Error screenshot

comment:1 Changed on Jan 16, 2010 at 6:43:39 AM by yedel@…

I wanted to add that the network connection is over WIFI. The connection is fast, but the reaction time on launching a new request are sometimes not that reactive (e.g. Skype speech quality gets affected). Perhaps that has to do with the issue (timeouts)?

comment:2 Changed on Apr 1, 2010 at 5:12:01 PM by dkocher

  • Platform set to Mac OS X 10.6

I can only explain this that the remote directory contents have changed since you have started the transfer explaining the SSH_FX_NO_SUCH... errors. A transfer progress of more than 100% on the other hand would suggest that files have been added locally after the transfer has started.

comment:3 Changed on Apr 1, 2010 at 5:12:29 PM by dkocher

  • Description modified (diff)

comment:4 Changed on Apr 1, 2010 at 5:47:36 PM by yedel@…

I just checked again and was able to reproduce the error. On the remote machine definitely nothing changed during the sync process: I shut down all processes before I left the office. I did not worked on he local machine during the transfer and the program that uses the folder in question is not running.

Perhaps the non-asci-characters in the file name appearing in the new attached screenshot of the error message.

Note that now the transfer is marked as complete, but I nether the less get an error-message.

Meanwhile using Os 10.6.3, Cyberduck 3.4.1

Changed on Apr 1, 2010 at 5:49:58 PM by yedel@…

Error message as of 1.4.2010

comment:5 Changed on Jul 23, 2010 at 1:44:50 PM by dkocher

  • Component changed from core to sftp
  • Milestone set to 3.6
  • Resolution set to worksforme
  • Status changed from new to closed

Please test with the latest snapshot build from http://update.cyberduck.ch/nightly/.

comment:6 Changed on Aug 5, 2010 at 5:26:37 PM by ye

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I tested build 6559, the problem persists. The Error message is now more informative:

SSH Fehler: Ordner kann nicht angelegt werden /Path... Failure (SSH_FX_FAILURE: An error occurred, but no specific error code exists to describe the failure.).

I get lots of these, al folder names contain non-asci-charachters (automatically generated by the creating program).

comment:7 follow-up: Changed on Aug 6, 2010 at 6:43:23 AM by ye

P.S.

The folders that can not be created, according to the error message, already exist.

So the problem seems to be that cyberduck? has some problems in verifying the existence of folders with non-asci characters (German Umlaute, Norwegian special characters, ...)

comment:8 in reply to: ↑ 7 Changed on Aug 6, 2010 at 2:43:04 PM by dkocher

Replying to ye:

P.S.

The folders that can not be created, according to the error message, already exist.

So the problem seems to be that cyberduck? has some problems in verifying the existence of folders with non-asci characters (German Umlaute, Norwegian special characters, ...)

Are the folder names displayed correctly in the browser when listing the directory?

comment:9 Changed on Aug 6, 2010 at 5:01:19 PM by ye

Yes the folder names are correctely displayed in the Browser as well as in the error message. I attached some examples (directory drawn to the shell and path copied):

~/Documents/Papers/2000/Österg»\ rd
~/Documents/Papers/2005/NEUBÜSER
~/Documents/Papers/1996/Szőnyi

Changed on Aug 8, 2010 at 6:07:54 AM by ye

Ziped folder with contend to produce the error

comment:10 follow-up: Changed on Aug 8, 2010 at 6:12:24 AM by ye

I attached a minimal example to reproduce the error. I put the attached folder "2000" on the dektop of both machines and then synced. By the way if the folder is already on the remote mashine and I try to copy it again I get the same error, so it is not sync specific.

Last edited on Aug 8, 2010 at 11:07:25 AM by dkocher (previous) (diff)

comment:11 in reply to: ↑ 10 Changed on Aug 8, 2010 at 11:29:50 AM by dkocher

Replying to ye:

I attached a minimal example to reproduce the error. I put the attached folder "2000" on the dektop of both machines and then synced. By the way if the folder is already on the remote mashine and I try to copy it again I get the same error, so it is not sync specific.

We always use UTF-8 encoded pathnames. Do you know what SSH server software you are connecting to? I tried with OpenSSH and don't have any issue.

comment:12 Changed on Aug 8, 2010 at 12:12:52 PM by ye

The remote machine which hosts the files is a MacPro OS, 10.6.4, 64-bit kenel.
The machine running Cyberduck is a Macbook Pro OS, 10.6.4, 32-bit kenel.
On both I canged nothing concening ssh.

The server which is tunneled runs Ubuntu. With:

ssh -v
OpenSSH_4.7p1 Debian-8ubuntu1.2, OpenSSL 0.9.8g 19 Oct 2007

comment:13 Changed on Aug 9, 2010 at 12:23:53 PM by dkocher

  • Summary changed from incomplete transfers to Creating directory fails with SSH_FX_FAILURE

comment:14 Changed on Aug 9, 2010 at 12:27:32 PM by dkocher

Replying to ye:

Can you connect directly to rule out that the tunnel is the culprit.

Last edited on Aug 9, 2010 at 12:28:10 PM by dkocher (previous) (diff)

comment:15 Changed on Aug 9, 2010 at 12:28:44 PM by dkocher

  • Milestone 3.6 deleted

comment:16 Changed on Aug 10, 2010 at 12:45:59 PM by ye

If I connect the laptop with an patch cable directly to the MacPro I get the same error.

comment:17 Changed on Aug 11, 2010 at 7:07:17 AM by ye

I get the same error message (i.e. that the folders that can not be created, according to the error message, and the folder already exists) when syncing my mail folder. Here the folder making problems contain no special characters, only spaces:

~/Library/Mail/Mailboxes/\ Mathi_sonstiges/Mail\ Archiv

But in the mail folder there are others with spaces which make no problems. Moreover I am here not able to make an minimal example, by making a folder only containing a folder of this name, or by copying and emptying this folder, to reproduce the error. Although the error message is reproducible by syncing the whole mail folder.

Also the problematic folder has the same permissions as the others and contain nothing special, as far as I see:

Mail Archiv yves$ ls -la
total 0
drwx------  17 yves  admin  578  9 Jun  2007 .
drwx------  13 yves  admin  442 16 Feb 13:53 ..
drwx------   2 yves  admin   68 13 Nov  2005 Mail  alt
drwxr-xr-x   8 yves  admin  272  6 Feb  2008 Mail  alt.mbox
drwxr-xr-x   8 yves  admin  272  6 Feb  2008 Mail 2000.mbox
drwxr-xr-x   8 yves  admin  272  6 Feb  2008 Mail 2001.mbox
drwxr-xr-x   8 yves  admin  272  6 Feb  2008 Mail 2002.mbox
drwxr-xr-x   8 yves  admin  272  6 Feb  2008 Mail 2003.mbox
drwx------   8 yves  admin  272  6 Feb  2008 Mail 2004.mbox
drwx------   4 yves  admin  136  6 Feb  2008 Mail 2005.mbox
drwx------   4 yves  admin  136  6 Feb  2008 Mail 2006.mbox
drwxr-xr-x   8 yves  admin  272  6 Feb  2008 Mail 96.mbox
drwxr-xr-x   8 yves  admin  272  6 Feb  2008 Mail 97.mbox
drwxr-xr-x   8 yves  admin  272  6 Feb  2008 Mail 98.mbox
drwxr-xr-x   8 yves  admin  272  6 Feb  2008 Mail 99.mbox
drwx------   5 yves  admin  170  9 Jun  2007 ebay archiv
drwx------   8 yves  admin  272 27 Mai  2008 ebay archiv.mbox
 Mathi_sonstiges yves$ ls -la
total 0
drwx------  13 yves  admin  442 16 Feb 13:53 .
drwx------  23 yves  admin  782 11 Aug 08:16 ..
drwx------  17 yves  admin  578  9 Jun  2007 Mail Archiv
drwx------   4 yves  admin  136 23 Jan  2008 Mail Archiv.mbox
drwx------   5 yves  admin  170 28 Sep  2009 Math Adm.mbox
drwx------   2 yves  admin   68 26 Aug  2008 Math bla
drwx------   5 yves  admin  170 12 Okt  2009 Math bla.mbox
drwxr-xr-x   9 yves  admin  306 20 Okt  2009 Referee.mbox

comment:18 Changed on Oct 1, 2010 at 5:42:05 PM by dkocher

  • Milestone set to 3.6.2
  • Resolution set to worksforme
  • Status changed from reopened to closed

Closed after 5154#comment:13.

comment:19 Changed on Dec 4, 2010 at 3:59:08 PM by ye

With version 3.8 I still get the error message as attached in comment 5.

Note: See TracTickets for help on using tickets.
swiss made software