Cyberduck Mountain Duck CLI

Opened 9 years ago

Closed 7 years ago

#4097 closed defect (fixed)

Connecting to wrong hostname with "@" in username

Reported by: nick@… Owned by: dkocher
Priority: normal Milestone: 3.4
Component: webdav Version: 4.1
Severity: normal Keywords:
Cc: Bp Architecture: Intel
Platform: Mac OS X 10.7

Description (last modified by dkocher)

As of version 3.4 (build 5755), the WebDav username field does not appear to be url-encoded. This breaks connections that have a username that's an email address. The connection url becomes: email@…@url.com

This was working in a recent previous version of CyberDuck but broke when the application was updated.

Change History (6)

comment:1 Changed 9 years ago by dkocher

  • Component changed from core to webdav
  • Description modified (diff)
  • Version changed from 3.3 to 3.4

comment:2 Changed 9 years ago by dkocher

  • Milestone set to 3.5
  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from WebDav username not URL encoded (regression) to Connecting to wrong hostname with "@" in username

In r5785.

comment:3 Changed 9 years ago by dkocher

  • Milestone changed from 3.5 to 3.4.2

comment:6 Changed 7 years ago by Bp

  • Architecture set to Intel
  • Cc Bp added
  • Milestone 3.4.2 deleted
  • Platform set to Mac OS X 10.7
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 3.4 to 4.1

comment:7 Changed 7 years ago by Bp

This issue appears in 4.1 again (using OS X Lion)

comment:8 Changed 7 years ago by dkocher

  • Milestone set to 3.4
  • Resolution set to fixed
  • Status changed from reopened to closed

We are tracking the regression in #6066. Please update to the snapshot build where the issue is resolved.

Note: See TracTickets for help on using tickets.
swiss made software