Cyberduck Mountain Duck CLI

#411 closed defect (fixed)

Lots of transfers and sleeping eats memory

Reported by: tas50@… Owned by: dkocher
Priority: normal Milestone: 2.8
Component: sftp Version: 2.5.5
Severity: major Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

I've been using Cyberduck for a while to transfer files to my Linux HTPC from a PowerMac G4 (Dual 867Mhz) for sometime without problems. I've recently started to use an iMac G5 1.8Ghz to do the transfers and I've been having lots of problems with memory use. I'm not sure if these issues always existed, but were masked since my PowerMac had 1.25 gigs and this iMac only has 512. The issue is that when I set a larger transfer over ssh, say 5 gigs, and come back the machine is barely responsive. After a little while things start to get back to normal, but I think this is the system paging Cyberduck to disk. When I open the terminal and go to top Cyberduck is using several gigs of VM. At the moment I have a transfer going and my machine is painfully slow. Here is a printout of top at the moment.

PID COMMAND      %CPU   TIME   #TH #PRTS #MREGS RPRVT  RSHRD  RSIZE  VSIZE
 1279 Cyberduck   78.5% 19:23.79  23   687 30166   285M+ 6.11M- 25.6M- 2.42G+

Change History (3)

comment:1 Changed on May 18, 2006 at 8:20:05 AM by dkocher

  • Component changed from core to sftp
  • Description modified (diff)
  • Resolution set to duplicate
  • Severity changed from normal to major
  • Status changed from new to closed

Duplicate for #251 (Issue for SFTP transfers only)

comment:2 Changed on Jun 3, 2006 at 4:56:45 PM by dkocher

  • Milestone set to 2.7
  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:3 Changed on Mar 9, 2007 at 9:00:52 PM by dkocher

  • Milestone changed from 2.9 to 2.8
  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software