Cyberduck Mountain Duck CLI

#4126 closed defect (fixed)

Handles symbolic links improperly.

Reported by: ian.vannman@… Owned by: dkocher
Priority: highest Milestone: 3.5
Component: ftp Version: 3.4.1
Severity: critical Keywords: symbolic link broken
Cc: _mal@… Architecture:
Platform: Mac OS X 10.6

Description (last modified by dkocher)

When listing a folder containing symbolic links Cyberduck 3.4.1 tries to change working directory to the path the symbolic link points to, not the symbolic link itself. That does usually not work as the server does not allow it:

CWD /
250 OK. Current directory is /
SYST
215 UNIX Type: L8
STAT /
213-STAT
lrwxr-xr-x    1 0        1982           76 Jan 20 23:12 HasseStina -> /private/Network/Servers/192.168.1.76/Volumes/2TB/familje filmer/HasseStina/
lrwxr-xr-x    1 0        1982           32 Jan 20 22:49 Kids -> /Users/chersoph/Desktop/2TB/Kids
lrwxr-xr-x    1 0        1982           34 Jan 20 22:49 Movies -> /Users/chersoph/Desktop/2TB/Movies
lrwxr-xr-x    1 0        1982           30 Jan 20 22:49 TV -> /Users/chersoph/Desktop/2TB/TV
lrwxr-xr-x    1 0        1982           32 Jan 11 22:01 ali dropbox -> /Volumes/WD230GB/ftp/ali dropbox
213 End.
CWD /private/Network/Servers/192.168.1.76/Volumes/2TB/familje filmer/HasseStina
550 Can't change directory to /private/Network/Servers/192.168.1.76/Volumes/2TB/familje filmer/HasseStina: No such file or directory
CWD /Users/chersoph/Desktop/2TB/Kids
550 Can't change directory to /Users/chersoph/Desktop/2TB/Kids: No such file or directory
CWD /Users/chersoph/Desktop/2TB/Movies
550 Can't change directory to /Users/chersoph/Desktop/2TB/Movies: No such file or directory
CWD /Users/chersoph/Desktop/2TB/TV
550 Can't change directory to /Users/chersoph/Desktop/2TB/TV: No such file or directory
CWD /Volumes/WD230GB/ftp/ali dropbox
550 Can't change directory to /Volumes/WD230GB/ftp/ali dropbox: No such file or directory

In Cyberduck 3.3b4 the applications behavior was the opposite:

CWD /
250 OK. Current directory is /
SYST
215 UNIX Type: L8
STAT /
213-STAT
lrwxr-xr-x    1 0        1982           76 Jan 20 23:12 HasseStina -> /private/Network/Servers/192.168.1.76/Volumes/2TB/familje filmer/HasseStina/
lrwxr-xr-x    1 0        1982           32 Jan 20 22:49 Kids -> /Users/chersoph/Desktop/2TB/Kids
lrwxr-xr-x    1 0        1982           34 Jan 20 22:49 Movies -> /Users/chersoph/Desktop/2TB/Movies
lrwxr-xr-x    1 0        1982           30 Jan 20 22:49 TV -> /Users/chersoph/Desktop/2TB/TV
lrwxr-xr-x    1 0        1982           32 Jan 11 22:01 ali dropbox -> /Volumes/WD230GB/ftp/ali dropbox
213 End.
CWD /HasseStina
250 OK. Current directory is /HasseStina
CWD /Kids
250 OK. Current directory is /Kids
CWD /Movies
250 OK. Current directory is /Movies
CWD /TV
250 OK. Current directory is /TV
CWD /ali dropbox
250 OK. Current directory is /ali dropbox
CWD /
250 OK. Current directory is /

Change History (4)

comment:1 Changed on Jan 20, 2010 at 10:39:51 PM by dkocher

  • Description modified (diff)
  • Milestone set to 3.5
  • Status changed from new to assigned
  • Summary changed from Cyberduck 3.4.1 handles symbolic links improperly. to Handles symbolic links improperly.

Thanks for posting a bug report about this regression.

comment:2 Changed on Jan 20, 2010 at 10:43:15 PM by dkocher

The regression was introduced in r5553 because of bug report #3763. Will have to analyze this more in depth.

comment:3 Changed on Mar 2, 2010 at 7:47:12 PM by chucksense

  • Cc _mal@… added

comment:4 Changed on May 25, 2010 at 12:51:41 PM by dkocher

  • Platform set to Mac OS X 10.6
  • Resolution set to fixed
  • Status changed from assigned to closed

Fix in r5989.

Note: See TracTickets for help on using tickets.
swiss made software