Cyberduck Mountain Duck CLI

#415 closed defect (worksforme)

Window created by New Browser (cmd-N) does not completely have focus until clicked

Reported by: pb@… Owned by: dkocher
Priority: normal Milestone: 3.0.3
Component: interface Version: 2.5.5
Severity: minor Keywords:
Cc: Architecture:
Platform:

Description

Reproduce:

  1. Press Cmd-N or select "New Browser" from file menu.
  1. New window created; it appears visually to have focus
  1. Notice that "Close Window" is greyed out in File menu; Toolbar options greyed out View menu; possibly others
  1. Click in new window
  1. Disabled options now available.

Change History (6)

comment:1 Changed on May 19, 2006 at 9:07:49 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I can't see this neither in 2.5.5 nor the current nightly build.

comment:2 Changed on May 19, 2006 at 10:30:05 AM by pb@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Ah, it turns out there's a precondition: Hide the toolbar first.

(I didn't realize this was a factor until I you marked it worksforme -- I always work with the toolbar hidden.)

comment:3 Changed on May 19, 2006 at 1:14:34 PM by dkocher

I can confirm this now. Additionally the navigation buttons below the toolbar are not validated when the toolbar is hidden which is a bug.

comment:4 Changed on Jan 22, 2007 at 5:20:42 PM by dkocher

  • Milestone set to 2.7.3
  • Resolution set to fixed
  • Status changed from reopened to closed

I can no longer see this (r2771).

comment:5 Changed on Jan 27, 2007 at 12:21:50 PM by dkocher

  • Milestone 2.7.3 deleted
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed on Oct 26, 2008 at 11:08:50 AM by dkocher

  • Milestone set to 3.0.3
  • Resolution set to worksforme
  • Status changed from reopened to closed

I can no longer reproduce this. Either this was fixed with an OS update or a unknown change in my own source.

Note: See TracTickets for help on using tickets.