Cyberduck Mountain Duck CLI

#4189 closed defect (thirdparty)

Connection Problem

Reported by: alan@… Owned by: dkocher
Priority: normal Milestone:
Component: ftp Version: 3.4.1
Severity: normal Keywords:
Cc: alan@… Architecture:
Platform:

Description (last modified by dkocher)

I am the client and the host. So I have log files for both ends.

See attached.

I can connect with html editor BBedit, but not with FTP client Cyberduck.

Totally at a loss.


We have 5 servers, and 4 we can connect to fine, one is giving us fits.

It worked up until it was "upgraded" a week ago. So some setting changed somewhere and literally have tried everything we can think of.

Figured a fresh look and different perspective is needed.

Below is the error message from CyberDuck,

Attached is a screen shot from the server log.

We can connect using BBedit, but no with CyberDuck or other FTP clients, only the HTML editor.

I have changed USER/PASS, added, deleted doesn't change things.

It has to be some setting that during some upgrade it toggled something.

Any ideas as where to look? or things to try?

Here is a test access I set up for you:

FTP HOST: srvr18.ud.net
USERNAME: cyberduck
PASSWORK: please

Thanks in advance.

Using the above login... was able to connect via BBedit, but no FTP client (CyberDuck)

Any help is appreciated.

Regards,

Alan

--

Alan Bird <alan@…> Phone: 502-212-7500 Universal Design, Inc. http://www.ud.net

--


FTP CLIENT

ERROR FROM CYBERDUCK

NOOP
220 FTP server ready.
USER nnep
331 User name OK, need password.
PASS ********
230 User logged in.
FEAT
500 Command "FEAT" unrecognized.
CWD /
250 CWD OK, "/".
STAT /
502 Command "STAT /" not implemented.
PASV
NOOP
220 FTP server ready.
USER nnep
331 User name OK, need password.
PASS ********
230 User logged in.
FEAT
500 Command "FEAT" unrecognized.
CWD /
250 CWD OK, "/".
STAT /
502 Command "STAT /" not implemented.
PASV

See attached screen shot of error message on server.

Attachments (2)

Picture 1.png (53.7 KB) - added by alan@… on Feb 3, 2010 at 9:40:15 PM.
FTP server error log screen shot
Screen shot 2010-02-05 at 09.46.30.png (254.8 KB) - added by alan@… on Feb 5, 2010 at 2:49:31 PM.
Screen shot, left is server, right is client

Download all attachments as: .zip

Change History (11)

Changed on Feb 3, 2010 at 9:40:15 PM by alan@…

FTP server error log screen shot

comment:1 follow-up: Changed on Feb 4, 2010 at 10:23:38 PM by yla

  • Resolution set to worksforme
  • Status changed from new to closed

You need to disable the STAT command with

defaults write ch.sudo.cyberduck ftp.sendStatListCommand false

which is described here?

comment:2 follow-up: Changed on Feb 5, 2010 at 1:23:12 PM by yla

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Merged from #4197:

Well ran the terminal command and still the same.

I think the problem is on our server end. That a setting there is incorrect.

I can still connect with BBedit, but not Cyberduck or any other FTP client.

CyberDuck works well with all the others, except for this one. Have compared setting and all look the same but obviously overlooking something.

Suggestions on server settings that would cause this?

comment:3 Changed on Feb 5, 2010 at 1:24:32 PM by yla

Please post the new transcript and/or screenshot

Changed on Feb 5, 2010 at 2:49:31 PM by alan@…

Screen shot, left is server, right is client

comment:4 Changed on Feb 5, 2010 at 2:50:55 PM by alan

Sent screen shot

Left is the log file from Server Right is the log file from Cyberduck client

comment:5 Changed on Feb 7, 2010 at 4:54:54 PM by dkocher

  • Description modified (diff)

comment:6 Changed on Feb 7, 2010 at 5:12:49 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from reopened to closed

The control connection is reset from the server immediately after sending the PASV command. It is a bug in Cyberduck that no error message is displayed.

comment:7 in reply to: ↑ 2 Changed on Feb 7, 2010 at 5:13:28 PM by dkocher

Replying to yla:

I can still connect with BBedit, but not Cyberduck or any other FTP client.

I would be interested in the transcript if available.

comment:8 in reply to: ↑ 1 Changed on Feb 7, 2010 at 5:16:46 PM by dkocher

Replying to yla:

You need to disable the STAT command with

That would only be needed if the response parsed is not interpreted properly and the file listing is improperly shown in the browser. In this case here where STAT is not even supported by the server, we automatically fall back to the other file listing methods available. The disabling of particular listing methods is only needed if no fallback is attempted because it is wrongly assumed that the previous method completed successfully.

comment:9 in reply to: ↑ description Changed on Feb 7, 2010 at 5:23:49 PM by dkocher

Replying to alan@…:

See attached screen shot of error message on server.

You can see that the server software says the client dropped the connection. From debugging the issue here I must say it rather looks like the server closes the socket.

Note: See TracTickets for help on using tickets.
swiss made software