Cyberduck Mountain Duck CLI

#4200 closed defect (thirdparty)

Subsequent commands fail after FEAT with error response

Reported by: joachim.n@… Owned by: dkocher
Priority: normal Milestone:
Component: ftp Version: 3.4.2
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Some of my bookmarks are not working:

  1. dblclick bookmark
  2. status shows I am logging in, ends with 'login successful'
  3. after this I remain at the bookmarks list, and status shows '25 bookmarks'.

Expected behaviour:

  1. I get shown a listing.

The log pane shows this:

USER username
331 User username OK. Password required
PASS ********
230-User username has group access to:  client0 
230 OK. Current restricted directory is /
FEAT
500 ?
PWD
211-Extensions supported:
 EPRT
 IDLE
 MDTM
 SIZE
 REST STREAM
 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
 MLSD
 TVFS
 ESTP
 PASV
 EPSV
 SPSV
 ESTA
 AUTH TLS
 PBSZ
 PROT
 UTF8
211 End.

Change History (7)

comment:1 Changed on Feb 6, 2010 at 6:58:30 PM by dkocher

  • Component changed from core to ftp
  • Description modified (diff)
  • Resolution set to thirdparty
  • Status changed from new to closed

This looks like a server issue to me. First it gives an 500 unknown command response to FEAT which is followed by a PWD request from Cyberduck. But the response for the working directory is not a path but the supported features response expected for the first command. Do you succeed connecting using another client? If so, please post the other transcript.

comment:2 Changed on Feb 6, 2010 at 11:46:04 PM by joachim.n@…

Yes, with Filezilla I connect fine.

Here is the transcript from Filezilla:

Status: Resolving address of [HOST URL] Status: Connecting to [IP:PORT]... Status: Connection established, waiting for welcome message... Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ---------- Response: 220-You are user number 1 of 50 allowed. Response: 220-Local time is now 00:52. Server port: 21. Response: 220-This is a private system - No anonymous login Response: 220-IPv6 connections are also welcome on this server. Response: 220 You will be disconnected after 15 minutes of inactivity. Command: USER [USERNAME] Response: 331 User [USERNAME] OK. Password required Command: PASS * Response: 230-User [USERNAME] has group access to: client0 Response: 230 OK. Current restricted directory is / Command: SYST Response: 215 UNIX Type: L8 Command: FEAT Response: 211-Extensions supported: Response: EPRT Response: IDLE Response: MDTM Response: SIZE Response: REST STREAM Response: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*; Response: MLSD Response: TVFS Response: ESTP Response: PASV Response: EPSV Response: SPSV Response: ESTA Response: AUTH TLS Response: PBSZ Response: PROT Response: UTF8 Response: 211 End. Command: OPTS UTF8 ON Response: 200 OK, UTF-8 enabled Status: Connected Status: Retrieving directory listing... Command: PWD Response: 257 "/" is your current location Command: TYPE I Response: 200 TYPE is now 8-bit binary Command: PASV Response: 227 Entering Passive Mode (174,142,29,77,213,126) Command: MLSD Response: 150 Accepted data connection Response: 226-ASCII Response: 226-Options: -l Response: 226 3 matches total Status: Directory listing successful

Version 0, edited on Feb 6, 2010 at 11:46:04 PM by joachim.n@… (next)

comment:3 Changed on Feb 22, 2010 at 12:15:17 PM by joachim.n@…

Please could this be reopened? I don't have the permisisons to do so.

comment:5 Changed on Jul 27, 2010 at 5:18:58 PM by dkocher

Still looks like a server issue. Don't know why it gives us a differnet response to FEAT than what Filezilla gets.

comment:6 Changed on Oct 14, 2010 at 1:40:30 PM by https://www.google.com/accounts/o8/id?id=aitoawmh-f0wgnplfvgrlux6ty2x7bviqtuxqmw

  • Resolution thirdparty deleted
  • Status changed from closed to reopened

This may well be a problem with the server being badly configured -- but other FTP clients I have tried with the same server Just Work -- just tried Flow and connected perfectly.

Therefore I think the problem lies with Cyberduck for falling over where other clients cope.

comment:7 Changed on Oct 15, 2010 at 11:12:09 AM by dkocher

  • Summary changed from opening bookmark gives no error but no directory listing shown to Subsequent commands fail after FEAT with error response
  • Version changed from 3.4.1 to 3.4.2

Is it possible to get access to the server for debugging the issue?

comment:8 Changed on Nov 18, 2010 at 5:35:13 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.