Cyberduck Mountain Duck CLI

#4213 closed defect (worksforme)

Fails to read absolute directory symlinks

Reported by: mike.kristopeit@… Owned by: dkocher
Priority: normal Milestone: 3.6
Component: sftp Version: 3.4.1
Severity: normal Keywords: links
Cc: Architecture: PPC
Platform: Mac OS X 10.5

Description

my server's default path is a directory full of links to other directories.

when i connect via FTP, they show as folder icons with link arrows and work fine... i can double click on them in cyberduck and browse the contents of the linked directory.

when i connect via SFTP, they show as file icons with link arrows, but they don't work. i can not follow their link path.

Change History (13)

comment:1 follow-up: Changed on Feb 12, 2010 at 9:39:16 AM by yla

Can you please post the (FTP) transcript from View → Log Drawer.

comment:2 in reply to: ↑ 1 Changed on Feb 13, 2010 at 9:55:15 AM by dkocher

Replying to yla:

Can you please post the (FTP) transcript from View → Log Drawer.

This will not help. As per the description, FTP listings work. Unfortunately, we do not have a transcript for SFTP connections. Do you succeed getting a correct directory listing with another client application?

comment:3 Changed on Feb 14, 2010 at 1:21:40 AM by mike.kristopeit@…

well, they show as links either way... the application should check the type of what it links to.

when i ssh directly, my shell shows them as directories and i can cd to them and everything works.

i thought SFTP was just FTP done over SSH? somewhere you aren't checking if links are directories.

comment:4 Changed on Feb 16, 2010 at 9:08:35 PM by mike.kristopeit@…

this might help...

from the file details: WHERE: /home/.sites/132/site12 J"@ KIND: symbolic link (file)

the J"@ text in the WHERE might be the problem.... but the "kind" is showing as "(file)" which is also incorrect.

could i change something on my server to make it work, or do you need to fix something in cyberduck?

comment:5 Changed on Feb 16, 2010 at 9:39:11 PM by mike.kristopeit@…

from ls -l when i ssh to the server for the same symlink:

lrwxrwxr-x    1 root     root           20 Jul 28  2009 www.websiteurl.com -> ../.sites/132/site12

nothing in there about J"@... looks like cyberduck bug.

maybe the problem is the file name "www.websiteurl.com" that has periods in it... maybe cyberduck is incorrectly identifying it as a ".com" file instead of a link to a directory... notice the leading "l" for link in the permissions settings...

Last edited on Aug 25, 2010 at 5:58:05 AM by dkocher (previous) (diff)

comment:6 Changed on Feb 17, 2010 at 12:50:29 AM by mike.kristopeit@…

and here is the FTP transcript from inside an SSH session on the server:

ftp> cd /home/sites
250 CWD command successful.
ftp> ls
227 Entering Passive Mode (208,78,244,174,201,138).
150 Opening ASCII mode data connection for file list
lrwxrwxr-x   1 root     root           20 Jul 28  2009 www.websiteurl.com -> ../.sites/132/site12
226 Transfer complete.
Last edited on Aug 25, 2010 at 5:58:18 AM by dkocher (previous) (diff)

comment:7 Changed on Feb 17, 2010 at 12:51:43 AM by mike.kristopeit@…

trying to fix the newlines... they were showing right on the form...

ftp> cd /home/sites
250 CWD command successful.
ftp> ls
227 Entering Passive Mode (208,78,244,174,201,138).
150 Opening ASCII mode data connection for file list
lrwxrwxr-x   1 root     root           19 Apr  9  2005 www.websiteurl.com -> ../.sites/148/site6
226 Transfer complete.
Last edited on Aug 25, 2010 at 5:58:48 AM by dkocher (previous) (diff)

comment:8 Changed on Feb 18, 2010 at 8:25:52 AM by mike.kristopeit@…

i just downloaded version 1.2 of Fugu, which is an SFTP only client... the directory symlinks worked fine and navigated to the proper directory when clicked on.

also the connections did not become stale.

your inattention to this seemingly critical, simple to fix, potential data loss causing bug has caused you to lose a user.

Fugu does not however provide back/forth history buttons... but they do provide a history list... other than that, they got you matched on features.

good luck.

comment:9 Changed on May 11, 2010 at 9:25:56 PM by GlowingApple

I don't know if I can shed any light on this, but I ran into this same problem.

For my particular example, I found that if the symlink was an absolute link (i.e. it linked to "/dir/dir2/dir3") Cyberduck saw it as a file and tried to download it (and subsequently failed). I then noticed that other links were being followed properly, and they were all relative links. So, once I changed the symlink to be a relative link (i.e. it now links to "../dir/dir2/dir3") Cyberduck follows it as if it were a regular directory.

Using the stock CLI sftp client, I was able to cd through the link in either case, but Cyberduck only followed it properly once it was relative.

comment:10 Changed on Jul 23, 2010 at 10:05:18 AM by dkocher

  • Architecture set to PPC
  • Platform set to Mac OS X 10.5
  • Summary changed from directory links work in FTP, but not SFTP... to Fails to read absolute directory symlinks

We now have a closer look as this didn't get the desired attention.

comment:11 Changed on Jul 23, 2010 at 10:11:30 AM by dkocher

Can you please help with the following debug information. Open a Terminal.app window and enter

defaults write ch.sudo.cyberduck logging warn

Then, list the folder in question. In the system.log of Console.app there should be a warnig message starting with

Cannot read symbolic link target of ...

Please post the error message here.

comment:12 follow-up: Changed on Aug 25, 2010 at 12:47:15 AM by http://glowingapple.myopenid.com/

Sorry for the delay, I don't think I had e-mail notification set up properly (I'm not sure it's set up properly now, but we'll see...).

I just tested this with logging set to warn and I can't duplicate the issue. I created some absolute links and relative links and other than lots of "No cached attributes for..." messages, Cyberduck followed both without error. I tried links to directories and to files. I also tried links that spanned different filesystems and they work as well.

Was this fixed in a more recent version? I'm running 3.5.1 (6117) on Mac OS X 10.6.4 (x86_64).

comment:13 in reply to: ↑ 12 Changed on Aug 25, 2010 at 6:01:39 AM by dkocher

  • Milestone set to 3.6
  • Resolution set to worksforme
  • Status changed from new to closed

Replying to http://glowingapple.myopenid.com/:

There was no change in the SFTP implementation that should affect this that I am aware of.

Note: See TracTickets for help on using tickets.
swiss made software