Cyberduck Mountain Duck CLI

#4258 closed defect (fixed)

Bookmark edit: typing is slow

Reported by: jariberg@… Owned by: dkocher
Priority: normal Milestone: 3.6
Component: interface Version: 3.4.1
Severity: normal Keywords: bookmark
Cc: jariberg@… Architecture:
Platform:

Description

Creating a new bookmark or editing an existing is slow. Typing in the input fields is delayed. Typing 'ftp' takes 3 seconds with a delay of about 1 second per character typed.

Change History (4)

comment:1 follow-up: Changed on Mar 3, 2010 at 10:42:47 AM by yla

Since Cyberduck rechecks the site availability and updates all dependent fields after each character this can cause a delay while typing. The delay depends on the performance of your machine.

comment:2 Changed on Mar 3, 2010 at 2:23:41 PM by jariberg@…

Why do that ? checking if the site is available could be done when trying to connect. If doing it on each keypress seems quite inefficient in my oppinion.

comment:3 in reply to: ↑ 1 Changed on Jul 28, 2010 at 3:12:09 PM by dkocher

  • Component changed from core to interface
  • Summary changed from bookmark edit: typing is slow to Bookmark edit: typing is slow

Replying to yla:

Since Cyberduck rechecks the site availability and updates all dependent fields after each character this can cause a delay while typing. The delay depends on the performance of your machine.

The delay is not caused by the reachability check but because of the update in the bookmark list.

comment:4 Changed on Jul 29, 2010 at 8:25:07 AM by dkocher

  • Milestone set to 3.6
  • Resolution set to fixed
  • Status changed from new to closed

In r6446.

Note: See TracTickets for help on using tickets.
swiss made software