Cyberduck Mountain Duck CLI

#4268 closed defect (worksforme)

FTP download folder empty

Reported by: also1412@… Owned by: dkocher
Priority: normal Milestone:
Component: ftp Version: 3.4.1
Severity: normal Keywords: download folder empty
Cc: Architecture:
Platform:

Description

This issue can be reproduced by connecting to a ftp server with username and password auth, and drag any folder in the server to desktop. CyberDuck tries to download it and the transmission window appears, but the downloaded folder is always empty in size, without any content regardless the state of original folder.

This issue causes huge inconvenience and I regard this download folder is a fundamental function of a FTP client. Hence I would rate it to be high priority. I noticed that there was someone reporting this issue in the forum but no one has submitted a ticket yet.

Current OS: MacOSX 10.6.2 CD version: 3.4.1(5780) Locale: Chinese Simplified

Change History (4)

comment:1 Changed on Mar 3, 2010 at 10:13:56 AM by yla

  • Component changed from core to ftp
  • Priority changed from highest to normal

Cannot reproduce this behavior. Please post the transcript from View → Log Drawer.

comment:2 Changed on Mar 3, 2010 at 10:32:06 AM by also1412@…

Hi, thanks for your reply. I have thought this maybe the problem of one particular server but I have used it on several FTP servers the problem still persists. Here is the transcript for one particular session, where I was trying to download a folder "img" which contains 2 images. It gives me 0 bytes downloaded:

220-Matrix FTP server ready.
220-This is a private system - No anonymous login
220-IPv6 connections are also welcome on this server.
220 Please note: files for your website must be stored under the htdocs directory.
USER anglolinguist.com
331 User anglolinguist.com OK. Password required
PASS ********
230 OK. Current directory is /htdocs
FEAT
211-Extensions supported:
 EPRT
 IDLE
 MDTM
 SIZE
 REST STREAM
 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
 MLSD
 ESTP
 PASV
 EPSV
 SPSV
 ESTA
211 End.
NOOP
200 Zzz...
CWD /htdocs/assets/img
250 OK. Current directory is /htdocs/assets/img
SYST
215 UNIX Type: L8
STAT /htdocs/assets/img
213-STAT
drwxrwxrwx    2 user_373 vweb         4096 Mar  2 23:47 .
drwx---rwx    3 user_373 vweb         4096 Mar  2 16:20 ..
-rw-rw-rw-    1 user_373 vweb        17926 Mar  2 16:20 logo-dark-big.png
-rw-rw-rw-    1 user_373 vweb        32029 Mar  2 23:47 malogo.png
213 End.
QUIT
221-Goodbye. You uploaded 0 and downloaded 0 kbytes.
221 Logout.
Last edited on Nov 10, 2010 at 2:38:17 PM by dkocher (previous) (diff)

comment:3 Changed on Mar 13, 2010 at 8:30:42 PM by s0mean

I am having exactly the same issue, with ftp folder downloading under OSX snow leopard. I have been suffering from this issue since the 1st version of Cyberduck in SL. Could anyone help?

The transcript code for one download session:

220-Matrix FTP server ready.
220-This is a private system - No anonymous login
220-IPv6 connections are also welcome on this server.
220 Please note: files for your website must be stored under the htdocs directory.
USER example.com
331 User example.com OK. Password required
PASS ********
230 OK. Current directory is /
FEAT
211-Extensions supported:
 EPRT
 IDLE
 MDTM
 SIZE
 REST STREAM
 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
 MLSD
 ESTP
 PASV
 EPSV
 SPSV
 ESTA
211 End.
NOOP
200 Zzz...
CWD /htdocs/about
250 OK. Current directory is /htdocs/about
SYST
215 UNIX Type: L8
STAT /htdocs/about
213-STAT
drwx---rwx    2 338591   500          4096 Jul 27  2009 .
drwx---rwx   27 338591   500          4096 Feb 17 08:28 ..
-rw----r--    1 338591   500          1435 Jul 27  2009 index.html
213 End.
QUIT
221-Goodbye. You uploaded 0 and downloaded 0 kbytes.
221 Logout.

comment:4 Changed on Jul 27, 2010 at 5:16:42 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot replicate this issue. If posting another transcript, please take the one from the log drawer in the Transfers window.

Note: See TracTickets for help on using tickets.
swiss made software