Cyberduck Mountain Duck CLI

#4297 closed defect (thirdparty)

Right Angle FTP Server STAT incompatibility

Reported by: markh@… Owned by: dkocher
Priority: normal Milestone:
Component: ftp Version: 3.4.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

We have a client that is running a BulletProof FTP Server that we just upgraded to the latest 2010 version. The Sales guy and at least one of his clients, use Cyberduck from his Mac to access files on the server. When connection to the server using Auto, Port, or PASV mode, the system gets to "Listing Directory" and then just hangs there. It retries twice and then fails. From the FTP Server console, I can see they are logged in and the last command is "STAT \". Is there a work around for this? You can test this by pointing at 66.213.252.131 and login with raguest/guest.

Please let me know ASAP, as I cannot easily downgrade the FTP server.

Mark Holm

Change History (4)

comment:1 Changed on Mar 14, 2010 at 12:18:23 PM by yla

  • Component changed from core to ftp
  • Priority changed from high to normal
  • Severity changed from blocker to normal
220 Right Angle FTP Server (BP2010)
USER raguest
331 Password required for raguest.
PASS ********
230 User raguest logged in.
FEAT
211-Extensions supported:
 CLNT
 MDTM
 PASV
 REST STREAM
 SIZE
211 End.
PWD
257 "/" is current directory.
NOOP
200 NOOP command successful.
SYST
215 UNIX Type: L8
STAT /
211- Server Status for User:raguest on RA2003srv :
211- (80.218.2.235:62456 <-> 192.168.10.104:21)
211-
211- Uploaded : 0 Kbytes
211- Downloaded : 0 Kbytes
211- 
211- End of STAT

comment:2 Changed on Mar 28, 2010 at 3:49:25 PM by dkocher

  • Summary changed from version 3.4.1 (5780) cannot connect to BulletProof FTP Server 2010 to Right Angle FTP Server STAT incompatibility

comment:3 Changed on Mar 28, 2010 at 4:00:07 PM by dkocher

As a workaround, disable the usage of STAT as described in the wiki.

Last edited on Oct 28, 2010 at 11:56:48 AM by dkocher (previous) (diff)

comment:4 Changed on Mar 28, 2010 at 4:03:02 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

The problem is that there is an invalid response line from this server. We fail to recognize the answer is complete and expect more to follow. The line 211- End of STAT is not a valid end marker but should be with a whitespace like 211 End.. Please report this bug to the server vendor.

Note: See TracTickets for help on using tickets.