Cyberduck Mountain Duck CLI

#4323 closed defect (thirdparty)

Giving false "upload failed" errors

Reported by: cyberduck@… Owned by: dkocher
Priority: normal Milestone:
Component: interface Version: 3.4.1
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.6

Description

I'm on an OS X 10.6 system, uploading to a Windows 7 machine. Occasionally when uploading a file to the Windows machine, I'll get a notification that the file transfer failed, saying "Cannot access file". However, the file has uploaded successfully to the Windows machine, as the checksums of the files on both machines match. I suppose this may be a quirk of whatever FTP server is on the Windows machine (it's not my machine), but even if it is a quirk of some FTP servers, it might not be a bad idea to have Cyberduck double check when it thinks a file hasn't uploaded successfully because of a 550 cannot access file error.

Change History (7)

comment:1 Changed on Apr 1, 2010 at 1:04:45 PM by cyberduck@…

Exact example of error given (while uploading a group of 11 files):

"FTP Error: Upload failed /incoming/Babylon 5/Season 2/babylon5.s02e09.dvdrip.proper- Cannot access file."

Actual file name was "babylon5.s02e09.dvdrip.proper-lol.avi", I'm not sure if the truncated display of the filename there means anything.

comment:2 Changed on Apr 1, 2010 at 1:06:27 PM by cyberduck@…

Well, that last comment didn't format correctly... the quoted error was on 3 lines, the first starting "FTP Error", the second starting "/incoming/", the third starting "Cannot access".

comment:3 Changed on Apr 1, 2010 at 3:03:11 PM by dkocher

  • Platform set to Mac OS X 10.6

Can you post the transcript by toggling the log from the error message at the bottom. The issue is most probably that either the permissions or the timestamp of the file uploaded cannot be changed.

comment:4 Changed on Apr 1, 2010 at 3:54:23 PM by dkocher

  • Summary changed from Cyberduck giving false "upload failed" errors to Giving false "upload failed" errors

comment:5 Changed on Apr 9, 2010 at 6:05:25 PM by cyberduck@…

Here's a log after uploading a different set of files (the failed one was /incoming/Babylon 5/Season 2/babylon5.s02e12.dvdrip.xvid-sfm.avi - this time no filename truncation):

213 modify=20100406052324; /incoming/Babylon 5/Season 2/babylon5.s02e20.dvdrip.xvid-sfm.avi PASV 227 Entering Passive Mode (192,168,1,106,204,106) STOR babylon5.s02e21.dvdrip.xvid-sfm.avi 150 Connection accepted 226 Transfer OK MFMT 20100406045308 babylon5.s02e21.dvdrip.xvid-sfm.avi 213 modify=20100406045308; /incoming/Babylon 5/Season 2/babylon5.s02e21.dvdrip.xvid-sfm.avi PASV 227 Entering Passive Mode (192,168,1,106,204,107) STOR babylon5.s02e22.dvdrip.xvid-sfm.avi 150 Connection accepted 226 Transfer OK MFMT 20100406051122 babylon5.s02e22.dvdrip.xvid-sfm.avi 213 modify=20100406051122; /incoming/Babylon 5/Season 2/babylon5.s02e22.dvdrip.xvid-sfm.avi QUIT 221 Goodbye

It seems that the transcript only goes so far back, and doesn't show the transfer for the relevant file. The FTP server in question doesn't allow files to be deleted/changed after they've been uploaded (at least, if I try to do such things as a separate action), and is on a Windows machine where permissions are (presumably) irrelevant, however the odd thing about this error is that it's not at all consistent. Sometimes I'll upload a bunch of files, and everything's fine, other times I get this odd error.

comment:6 follow-up: Changed on Apr 21, 2010 at 12:09:33 PM by cyberduck@…

Ok, finally I got this error happening to one of the last files transferred, so it's all in the transcript:


MFMT 20100420124729 Gag.Real.DVDRip.XviD-SFM.avi

213 modify=20100420124729; /incoming/Babylon 5/Season 4/Extras/Gag.Real.DVDRip.XviD-SFM.avi

PASV

227 Entering Passive Mode (192,168,1,106,214,237)

STOR No.Surrender.No.Retreat.DVD.Suite.DVDRip.XviD-SFM.avi

150 Connection accepted

226 Transfer OK

MFMT 20100420183244 No.Surrender.No.Retreat.DVD.Suite.DVDRip.XviD-SFM.avi

550 Cannot access file

QUIT

221 Goodbye


Again, this only seems to happen half the time. Also, the bug tracker doesn't seem to bother putting single new lines on their own line, hence the double spacing in the transcript.

comment:7 in reply to: ↑ 6 Changed on Apr 25, 2010 at 3:58:18 AM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

Replying to cyberduck@…:

MFMT 20100420124729 Gag.Real.DVDRip.XviD-SFM.avi
213 modify=20100420124729; /incoming/Babylon 5/Season 4/Extras/Gag.Real.DVDRip.XviD-SFM.avi
PASV
227 Entering Passive Mode (192,168,1,106,214,237)
STOR No.Surrender.No.Retreat.DVD.Suite.DVDRip.XviD-SFM.avi
150 Connection accepted
226 Transfer OK
MFMT 20100420183244 No.Surrender.No.Retreat.DVD.Suite.DVDRip.XviD-SFM.avi
550 Cannot access file
QUIT
221 Goodbye

Writing the modification date after the upload completes fails for the given file. This is possibly a permission issue with the server or even a bug. Try to also check Change permissions in the Upload Transfer preferences.

Note: See TracTickets for help on using tickets.
swiss made software