Cyberduck Mountain Duck CLI

#4356 closed defect (worksforme)

On S3 connection, unable to open final directory in hierarchy to download file

Reported by: neil@… Owned by: dkocher
Priority: normal Milestone:
Component: s3 Version: 3.4.1
Severity: critical Keywords:
Cc: Architecture:
Platform:

Description

I just installed Cyberduck and am trying to download a file from my Amazon S3 account. I connected fine and could traverse through the hierarchy of folders fine until I got to the final (most descendent) set of folders in the hierarchy. Instead of showing as folders, these instead show as files (right-clicking and choosing Info shows "Unknown" kind) and when I double-clicked one it actually downloaded a 38 byte file with the following contents:

{E40327BF-517A-46e8-A6C3-AF51BC263F59}

When I look at my S3 account through the S3fox firefox plugin, these appear as normal folders and I can open them to see the actual files inside, so it's definitely a Cyberduck issue.

I don't know if this is related or not, but each of these folders contains only a single file which happens to be the same name as the folder plus an extension. For example, one of these folders is named "10-03-31" and it contains just one file named "10-03-31.sql.gz"

Change History (3)

comment:1 Changed on Apr 1, 2010 at 10:08:23 AM by dkocher

What application have you used to create these folders? The issue is that S3 lacks the concept of directories and these are just placeholder (marker) files with different applications having different strategies on their representation. We recognize directory markes with a MIME type of application/x-directory. No directory marker is needed if a file with the same prefix exists.

comment:2 Changed on Apr 1, 2010 at 10:17:40 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

The S3fox plugin has a dumb behaviour of adding the _$folder$ postfix to a directory name placeholder file. We will not support this but only directory markers with MIME type set as described above or directories just implied by the key prefix.

comment:3 Changed on Apr 1, 2010 at 3:54:37 PM by neil@…

My ISP automatically creates these files (they're backups) so I don't know what tools they're using. After seeing your comment, I downloaded yet another S3 client called S3Hub and it shows the folders fine as well, so Cyberduck remains the only client I've tried that suffers from this issue. I'll just use S3Hub instead.

Note: See TracTickets for help on using tickets.
swiss made software