Cyberduck Mountain Duck CLI

#4361 closed defect (thirdparty)

Symbolic links broken with STAT

Reported by: aknapp@… Owned by: dkocher
Priority: high Milestone:
Component: ftp Version: 3.4.1
Severity: normal Keywords: symbolic links
Cc: Architecture:
Platform: Mac OS X 10.6

Description

So, symlinks seem to be broken from 3.3.1 onwards. I've attached some screenshots that show the problem.

Basically, in 3.3, you are able to follow symlinks (they show up as directories, if that's what they are). In versions > 3.3, they show up as files (even though they link to directories) and Cyberduck tries to download them as files.

I've tried it on 2 different machines and get the same functionality.

Let me know if you need any other info.

Attachments (3)

working-screenshot.tar.gz (139.0 KB) - added by aknapp@… on Apr 2, 2010 at 10:21:54 PM.
working screenshot
non-working-screenshot.tar.gz (134.4 KB) - added by aknapp@… on Apr 2, 2010 at 10:22:31 PM.
non working screenshot
log-drawer-3.4.1.rtf (154.6 KB) - added by aknapp@… on Apr 5, 2010 at 6:34:48 PM.
log drawer transcript

Download all attachments as: .zip

Change History (7)

Changed on Apr 2, 2010 at 10:21:54 PM by aknapp@…

working screenshot

Changed on Apr 2, 2010 at 10:22:31 PM by aknapp@…

non working screenshot

comment:1 Changed on Apr 3, 2010 at 3:48:14 PM by dkocher

Can you post the transcript from the log drawer of the browser window using 3.4.1.

Changed on Apr 5, 2010 at 6:34:48 PM by aknapp@…

log drawer transcript

comment:2 Changed on Apr 5, 2010 at 6:35:19 PM by aknapp@…

Ok, I attached the output from the log drawer.

comment:3 Changed on Apr 10, 2010 at 1:59:56 PM by dkocher

  • Component changed from core to ftp
STAT /
213-STAT
lrwxrwxrwx    1 1000       deploy             63 Apr  2 12:16 1-hopesrise -> /var/www/apps/topspin/shared/mounts/content/media/ftp_uploads/1
213 End.
CWD /var/www/apps/topspin/shared/mounts/content/media/ftp_uploads/1
550 Can't change directory to /var/www/apps/topspin/shared/mounts/content/media/ftp_uploads/1: No such file or directory

The problem is that these links are pointing to directories that are not accessible via FTP. This is a bug in the server implementation of STAT.

The workaround is to disable? the use of STAT using a hidden preference for Cyberduck.

comment:4 Changed on Apr 10, 2010 at 2:01:48 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed
  • Summary changed from symlinks broken from 3.3.1 onwards to Symbolic links broken with STAT

Please report this bug to the server software vendor.

Note: See TracTickets for help on using tickets.
swiss made software