Cyberduck Mountain Duck CLI

#4415 closed defect (worksforme)

Charset incompatiblity with Freebox for uploads

Reported by: sd <sd55@…> Owned by: dkocher
Priority: normal Milestone:
Component: ftp Version: 3.4.2
Severity: normal Keywords: encoding
Cc: Architecture:
Platform: Mac OS X 10.6

Description

When uploading files to my "Freebox" (french linux based TV/ADSL box), French caracters such as "è" are not properly handled. The connection is set up to use the correct ISO-8859-1 encoding. It is correct because in this way I can correctly see the names of files already on the server. If I upload a file from Finder called "test çé.avi" it will appear on the Freebox side like "test c?e?.avi". I have to use the Information window to change it to "test çé.avi", and then it will be OK. I think that Cyberduck forgets to transform the UTF-8 encoded name in Mac OS's Finder to a ISO-8859-1 encoding while uploading it.

This bug is not a duplicate of ticket #2279 even if quite close. I precise that other FTP clients do not need to have the encoding set, and will correctly transfer the files with their correct non ASCII names. Far more convenient!

Change History (5)

comment:1 in reply to: ↑ description Changed on Apr 25, 2010 at 6:56:27 AM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

Replying to sd <sd55@…>:

I think that Cyberduck forgets to transform the UTF-8 encoded name in Mac OS's Finder to a ISO-8859-1 encoding while uploading it.

Thanks for your analysis on this. We do make sure that the writer has the correct character encoding set and I must assume this is a server issue. Could you file a bug at Freebox and see what they have to say.

comment:2 follow-up: Changed on May 13, 2010 at 2:50:18 PM by sd <sd55@…>

  • Resolution thirdparty deleted
  • Status changed from closed to reopened

I would like to reopen the bug... 1/ I do not think Freebox will ever take the 'bug' into account 2/ Only Cyberduck gives this trouble. Everything is OK with other FTP clients as Transmit or Fetch

comment:3 Changed on Jul 27, 2010 at 5:14:28 PM by dkocher

  • Summary changed from encoding not correctly taken into account when uploading to Charset incompatiblity with Freebox for uploads

comment:4 in reply to: ↑ 2 Changed on Dec 3, 2010 at 4:42:30 PM by dkocher

Replying to sd <sd55@…>:

I would like to reopen the bug... 1/ I do not think Freebox will ever take the 'bug' into account 2/ Only Cyberduck gives this trouble. Everything is OK with other FTP clients as Transmit or Fetch

Can you give me access to such a box to debug the issue?

comment:5 Changed on Dec 8, 2010 at 3:50:21 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software