Cyberduck Mountain Duck CLI

#4419 closed defect (fixed)

Overwrite files causes append

Reported by: shapiroe Owned by: dkocher
Priority: normal Milestone: 3.5
Component: s3 Version: 3.4.2
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.6

Description

If I copy a JPG or MOV file from S3 to the Finder, it works fine...

If I then make a change (or not) on S3, and copy the file again, I get the "resume/overwrite/rename" dialog. I choose Overwrite. However, it actually appends to the existing file. So, my local files all get corrupted because they are now twice, then 3 times... then 4x as big.

Change History (6)

comment:1 Changed on Apr 23, 2010 at 2:54:02 AM by shapiroe

It also happens with TXT files.

comment:2 Changed on Apr 25, 2010 at 3:58:37 AM by dkocher

  • Component changed from core to s3
  • Milestone set to 3.5
  • Status changed from new to assigned
  • Summary changed from Overwrite files from S3 to Finder causes append to Overwrite files causes append

comment:3 Changed on Apr 25, 2010 at 4:00:32 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r5913.

comment:4 follow-up: Changed on Mar 1, 2019 at 8:34:18 PM by KeeLargo

  • Resolution fixed deleted
  • Status changed from closed to reopened

Defect still exists when using SFTP

1) Cyberduck 6.9.4
2) Windows 10
3) Connect to SFTP server
4) Local and remote files are text with ".htm" extension
5) Upload file by drag and drop
6) Choose Overwrite from dropdown
7) Click on Continue
8) Local file is appended to remote file

comment:5 in reply to: ↑ 4 Changed on Mar 12, 2019 at 9:10:50 AM by dkocher

Replying to KeeLargo:

Defect still exists when using SFTP

1) Cyberduck 6.9.4
2) Windows 10
3) Connect to SFTP server
4) Local and remote files are text with ".htm" extension
5) Upload file by drag and drop
6) Choose Overwrite from dropdown
7) Click on Continue
8) Local file is appended to remote file

I cannot reproduce this error. Please open a new ticket if the bug persists.

comment:6 Changed on Mar 12, 2019 at 9:10:54 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software