Cyberduck Mountain Duck CLI

#4445 closed defect (duplicate)

Unable to connect to S3 from Snow Leopard

Reported by: rwhendrickson@… Owned by: dkocher
Priority: normal Milestone:
Component: s3 Version: 3.4.2
Severity: blocker Keywords:
Cc: Architecture:
Platform: Mac OS X 10.6

Description

Running Cyberduck 3.4.2 on a MacBook Pro with Snow Leopard 10.6.3. After entering my Amazon credentials, nothing happens. On an older G5 running Leopard, Cyberduck connects successfully so I know my credentials are good.

Change History (4)

comment:1 Changed on May 15, 2010 at 9:00:30 AM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate for #4456. Please let me know if you can find anything in the system.log (open Console.app from /Applications/Utilities).

comment:2 follow-up: Changed on May 17, 2010 at 4:14:45 PM by rwhendrickson@…

Following messages in console log: 5/17/10 12:03:47 PM [0x0-0x27027].ch.sudo.cyberduck[1721] 2010-05-17 12:03:47,145 [main] ERROR org.rococoa.callback - Exception calling method for selector sheetDidClose:returnCode:contextInfo:

5/17/10 12:03:47 PM [0x0-0x27027].ch.sudo.cyberduck[1721] Caused by: org.apache.commons.logging.LogConfigurationException: No suitable Log constructor [Ljava.lang.Class;@13d1402 for org.apache.commons.logging.impl.Log4JLogger (Caused by java.lang.NoClassDefFoundError: org/apache/log4j/Category)

5/17/10 12:03:47 PM [0x0-0x27027].ch.sudo.cyberduck[1721] Caused by: org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException: No suitable Log constructor [Ljava.lang.Class;@13d1402 for org.apache.commons.logging.impl.Log4JLogger (Caused by java.lang.NoClassDefFoundError: org/apache/log4j/Category) (Caused by org.apache.commons.logging.LogConfigurationException: No suitable Log constructor [Ljava.lang.Class;@13d1402 for org.apache.commons.logging.impl.Log4JLogger (Caused by java.lang.NoClassDefFoundError: org/apache/log4j/Category))

comment:3 Changed on May 18, 2010 at 8:37:41 AM by yla

Make sure that the server name in the bookmark is set to s3.amazonaws.com instead of aws.amazonaws.com. Then please try again.

comment:4 in reply to: ↑ 2 Changed on May 18, 2010 at 9:28:33 AM by dkocher

Replying to rwhendrickson@…:

Following messages in console log: 5/17/10 12:03:47 PM [0x0-0x27027].ch.sudo.cyberduck[1721] 2010-05-17 12:03:47,145 [main] ERROR org.rococoa.callback - Exception calling method for selector sheetDidClose:returnCode:contextInfo:

5/17/10 12:03:47 PM [0x0-0x27027].ch.sudo.cyberduck[1721] Caused by: org.apache.commons.logging.LogConfigurationException: No suitable Log constructor [Ljava.lang.Class;@13d1402 for org.apache.commons.logging.impl.Log4JLogger (Caused by java.lang.NoClassDefFoundError: org/apache/log4j/Category)

5/17/10 12:03:47 PM [0x0-0x27027].ch.sudo.cyberduck[1721] Caused by: org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException: No suitable Log constructor [Ljava.lang.Class;@13d1402 for org.apache.commons.logging.impl.Log4JLogger (Caused by java.lang.NoClassDefFoundError: org/apache/log4j/Category) (Caused by org.apache.commons.logging.LogConfigurationException: No suitable Log constructor [Ljava.lang.Class;@13d1402 for org.apache.commons.logging.impl.Log4JLogger (Caused by java.lang.NoClassDefFoundError: org/apache/log4j/Category))

Please refer to #3641.

Note: See TracTickets for help on using tickets.
swiss made software