Cyberduck Mountain Duck CLI

#45 closed defect (duplicate)

Timezone Errors Cause Problematic Synchroniaztion

Reported by: cyberduck-trac@… Owned by: dkocher
Priority: normal Milestone: 3.0
Component: core Version: 2.5.2
Severity: critical Keywords:
Cc: Architecture:
Platform:

Description

Cyberduck incorrectly displays file modification dates for some servers, but not others. It seems to be adding 8 hours (my timezone is GMT-0800), which results in file modification dates in the future.

This has catastrophic results for synchronize, as Cyberduck will always download files.

The time on the server is correct, and every other client that I've tried (Transmit, lftp, ftp) doesn't exhibit this problem. With an improper modification timestamp, the synchronize function is very dangerous! (I know someone who lost some source code because of this bug, which is why I filed it. And yes, they should have backed up.)

Change History (6)

comment:1 Changed on Dec 20, 2005 at 12:35:51 PM by dkocher

  • Status changed from new to assigned

comment:2 Changed on Mar 3, 2006 at 8:54:22 AM by dkocher

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of newly opened #249.

comment:3 Changed on Mar 25, 2006 at 8:43:27 PM by dkocher

  • Milestone 2.6 deleted

comment:4 Changed on May 29, 2006 at 4:15:11 PM by dkocher

  • Milestone set to 2.6.5

comment:5 Changed on Feb 12, 2007 at 1:45:06 PM by dkocher

  • Milestone changed from 2.8 to 2.9

Milestone 2.8 deleted

Note: See TracTickets for help on using tickets.
swiss made software