Cyberduck Mountain Duck CLI

#4509 closed defect (thirdparty)

TLS negogitation fails with OpenSSL 0.9.8n

Reported by: anonymous Owned by: dkocher
Priority: normal Milestone:
Component: ftp-tls Version: 3.4.2
Severity: normal Keywords: OpenSSL
Cc: Architecture:
Platform: Mac OS X 10.6

Description

After moving to a new server, Cyberduck is reporting an error on upload/download saying that it can't connect. (I move back to the previous server and everything is fine). The webhost tech person comments are included below. He claims it is an OpenSSL-Cyberduck problem. This is *way* out of my expertise. Is his comment plausible?

Webhost Comments: The problem is more likely that there's a constant updating of code among the encryption providers (in our case OpenSSL) and the encryption users (the ftp servers and clients.) If they aren't both on the same page, encryption fails.

FileZilla successfully negotiates with the OpenSSL encryption being used (OpenSSL 0.9.8n 24 Mar 2010) . Version 1.0 (released five days later) broke all sorts of stuff so we had to revert to the preceding.

Unfortunately, even if we wanted to, we have no way to support CyberDuck - we don't have a new enough Mac to run it. The only way that we can help you solve this is to have you try to connect with the latest FZ (3.3.21) and go from there.

Change History (2)

comment:1 Changed on Jun 1, 2010 at 1:07:24 AM by dkocher

  • Component changed from core to ftp-tls
  • Summary changed from OpenSSL 0.9.8n 24 Mar 2010 to TLS negogitation fails with OpenSSL 0.9.8n

Please let me know the error message in Cyberduck and the server address so we can have a look at the TLS negogiation issue.

comment:2 Changed on Aug 24, 2010 at 6:20:53 AM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software