Cyberduck Mountain Duck CLI

#4551 closed enhancement (worksforme)

Upload Error Handling

Reported by: lukebacon Owned by: dkocher
Priority: normal Milestone: 3.6
Component: googledrive Version: 3.5
Severity: normal Keywords: Google Docs, Google
Cc: me@… Architecture: Intel
Platform: Mac OS X 10.6

Description

Could the handling of errors caused by Google Docs Standard be improved? (i.e. those caused by attempting to upload a file which is not in a Google Docs format) - at present any one of these errors (even a stray .DS_Store file) seems to cause any bulk upload to stop, with only two options - Cancel (which cancels the entire upload) or 'Try Again' (which starts the entire upload from scratch, often creating duplicate files until the same error is encountered). Could a Skip/Ignore option be added, or a preference to exclude such files?

Change History (4)

comment:1 Changed on Jun 13, 2010 at 1:31:03 PM by lukebacon

  • Cc me@… added

comment:2 Changed on Jun 14, 2010 at 2:20:21 PM by dkocher

  • Milestone set to 3.6
  • Status changed from new to assigned
  • Summary changed from Google Docs Upload Error Handling to Upload Error Handling

comment:3 in reply to: ↑ description Changed on Jul 15, 2010 at 5:42:17 PM by dkocher

Replying to lukebacon:

Could the handling of errors caused by Google Docs Standard be improved? (i.e. those caused by attempting to upload a file which is not in a Google Docs format) - at present any one of these errors (even a stray .DS_Store file) seems to cause any bulk upload to stop, with only two options - Cancel (which cancels the entire upload) or 'Try Again' (which starts the entire upload from scratch, often creating duplicate files until the same error is encountered). Could a Skip/Ignore option be added, or a preference to exclude such files?

All other files should upload just fine. The error report is at the end of the transfer listing all failed items from the transfer.

comment:4 Changed on Jul 22, 2010 at 3:54:42 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

The .DS_Store files are skipped by default using the upload regular expression for excluded files. See Preferences → Transfers → Filter → Skip files matching regular expression.

Note: See TracTickets for help on using tickets.
swiss made software