Cyberduck Mountain Duck CLI

#4561 closed defect (worksforme)

java.lang.ClassNotFoundException: org.objectweb.asm.Type

Reported by: jurgen Owned by: dkocher
Priority: high Milestone:
Component: core Version: 3.5
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description (last modified by dkocher)

Cyberduck 3.5.1 will not start on Mac OS X 10.6.4. The icon appears briefly, then disapears again. Console output follows:

18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]	[LaunchRunner Error] ch.cyberduck.ui.cocoa.MainApplication.main(String[]) threw an exception:
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]	java.lang.NoClassDefFoundError: org/objectweb/asm/Type
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at net.sf.cglib.core.TypeUtils.parseType(TypeUtils.java:180)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at net.sf.cglib.core.KeyFactory.<clinit>(KeyFactory.java:66)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at net.sf.cglib.proxy.Enhancer.<clinit>(Enhancer.java:69)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at org.rococoa.Rococoa.createProxy(Rococoa.java:173)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at org.rococoa.Rococoa.wrap(Rococoa.java:123)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at org.rococoa.Rococoa.createClass(Rococoa.java:49)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at org.rococoa.cocoa.foundation.NSObject.<clinit>(NSObject.java:28)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:48)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at java.lang.reflect.Method.invoke(Method.java:597)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at apple.launcher.LaunchRunner.run(LaunchRunner.java:115)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]	Caused by: java.lang.ClassNotFoundException: org.objectweb.asm.Type
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at java.security.AccessController.doPrivileged(Native Method)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at sun.misc.Launcher$ExtClassLoader.findClass(Launcher.java:229)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
18.06.10 13:35:08 	[0x0-0xd60d6].ch.sudo.cyberduck[7707]		... 15 more

Change History (5)

comment:1 Changed on Jul 9, 2010 at 6:44:46 AM by dkocher

  • Description modified (diff)

comment:2 Changed on Jul 9, 2010 at 6:45:47 AM by dkocher

  • Summary changed from Cyberduck 3.5.1 will not start on Mac OS X 10.6.3/10.6.4 to java.lang.ClassNotFoundException: org.objectweb.asm.Type

comment:3 follow-up: Changed on Jul 22, 2010 at 4:37:37 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Do you have a asm.jar installed somewhere in your classpath like Library/Java. I cannot replicate this issue.

comment:4 in reply to: ↑ 3 ; follow-up: Changed on Jul 23, 2010 at 10:27:55 AM by jurgen

Replying to dkocher:

Do you have a asm.jar installed somewhere in your classpath like Library/Java. I cannot replicate this issue.

The problem was not asm.jar, but cglib-2.2.jar, which was in /Library/Java/Extensions. After removing this lib, Cyberduck starts up again. However, shouldn't the classpath be set such that locally available resources, like Cyberduck.app/Contents/Resources/Java/cglib-2.2.jar are preferred over ones available in the System?

comment:5 in reply to: ↑ 4 Changed on Jul 23, 2010 at 11:24:01 AM by dkocher

Replying to jurgen:

Replying to dkocher:

Do you have a asm.jar installed somewhere in your classpath like Library/Java. I cannot replicate this issue.

The problem was not asm.jar, but cglib-2.2.jar, which was in /Library/Java/Extensions. After removing this lib, Cyberduck starts up again. However, shouldn't the classpath be set such that locally available resources, like Cyberduck.app/Contents/Resources/Java/cglib-2.2.jar are preferred over ones available in the System?

There is no way I know to change this behaviour. Installed libraries always take precedence in the classpath.

Note: See TracTickets for help on using tickets.
swiss made software