Cyberduck Mountain Duck CLI

#4731 closed defect (worksforme)

Trailing slash always appended

Reported by: mrn-lmb Owned by: dkocher
Priority: normal Milestone: 3.6
Component: webdav Version: 3.5
Severity: normal Keywords: connecting to webdav server
Cc: Architecture: Intel
Platform: Mac OS X 10.5

Description

We have installed a program called filerun here and to connect to it via webdav you have to put the path in as follows

http://address/dav.php/

you must have a trailing slash at the end ... for some reason cyberduck removes this. Is there anyway to change this? I have also tried the program Transmit and it works fine with that.

Any help appreciated :)

Marc

Change History (8)

comment:1 Changed on Jul 9, 2010 at 6:27:40 AM by dkocher

  • Summary changed from Connecting to a webdav server to Trailing slash always appended

comment:2 Changed on Jul 9, 2010 at 9:48:38 AM by mrn-lmb

I tried even with out the trailing / but I get this

abs_path requested

comment:3 Changed on Jul 9, 2010 at 12:13:06 PM by dkocher

Related to #4527.

comment:4 Changed on Jul 9, 2010 at 1:29:29 PM by dkocher

  • Milestone set to 3.7
  • Status changed from new to assigned

comment:5 Changed on Jul 27, 2010 at 4:16:22 PM by dkocher

  • Milestone changed from 3.7 to 3.6
  • Resolution set to worksforme
  • Status changed from assigned to closed

I cannot replicate this. The trailing slash is not removed.

comment:6 Changed on Jul 27, 2010 at 4:17:57 PM by dkocher

Actually when accessing a directory resource over WebDAV, we always append a trailing / to the path.

comment:7 in reply to: ↑ description Changed on Jul 27, 2010 at 4:18:32 PM by dkocher

Replying to mrn-lmb:

if this is still an issue, please post the transcript from the log drawer.

comment:8 Changed on Jul 28, 2010 at 9:20:04 AM by mrn-lmb

Nothing appears in the log draw

Feel free to try yourselves

I need to connect to this server

http://demo.filerun.com/dav.php/

It works with the program transmit for OS X but with Cyberduck i just get abs_path requested...

Note: See TracTickets for help on using tickets.
swiss made software