Cyberduck Mountain Duck CLI

#5102 closed defect (fixed)

Synchronize Upload also downloads

Reported by: https://www.google.com/accounts/o8/id?id=aitoawnd9asfm5sa4wamo0erhoogq7cxykt9_do Owned by: dkocher
Priority: normal Milestone: 3.6
Component: core Version: 3.5.1
Severity: normal Keywords: synchronize upload
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

I am using Cyberduck 3.5.1 (6117) to maintain a Joomla website from my laptop. I wanted to upgrade Joomla and downloaded an upgrade pack which is a tar file containing only the changed files. Then I used Cyberduck, selected the httpdocs from my website and choose Synchronize from the action menu. Then I choose the local directory containing the new file (same structure as httpdocs but a subset). In the selector that came up after Cyberduck logged in I choose Upload. I was very surprised to see later that one local directory (the directory templates that contains additional stuff on the server) had been updated in the other direction, i.e. the subdirectories on the server that were not on the laptop had been downloaded. How can this be?

Change History (7)

comment:1 Changed on Aug 14, 2010 at 1:32:14 PM by https://www.google.com/accounts/o8/id?id=aitoawnd9asfm5sa4wamo0erhoogq7cxykt9_do

I took a more detailed look and it appears that the problem is slightly less severe. It does not download files but only the directory structure. I.e. it reconstructs the directory tree on the local site but with empty directories. Still I think this is fundamentally wrong for two reasons:

  1. Upload should make NO changes to the local files. Even as in most cases empty directories are harmless there can be situations where an extra directory, though empty, has a semantic meaning.
  2. It appears that Cyberduck is also making listings of remote directories that are not present in the local tree. I guess this is the reason that it creates the local directories: to have the same structure on both sides. Anyway, I am on a slow internet connection, so it takes hours to make the remote listing, and a lot of it is useless because there is no local counterpart, if the local tree contains only a small update to the remote tree, as it is in my case. I think it should skip those remote directories that are not in the local tree.

comment:2 Changed on Aug 16, 2010 at 7:22:00 PM by dkocher

  • Milestone set to 3.6

comment:3 Changed on Aug 16, 2010 at 7:42:47 PM by dkocher

  • Status changed from new to assigned

Confirmed. Can reproduce.

comment:4 follow-up: Changed on Aug 24, 2010 at 6:08:18 AM by opfeifer

Similar problem here, using v. 3.3 (5552). Even though 'upload' is selected, it also DOWNLOADS FILES during the 'synchronize' operation. Sorry my Version is outdated, but there is no note about that in the version history. Will confirm if 3.5 has this solved, but I guess not?! Also, as a feature request: Upload and delete (locally) missing files would be great to maintain consistency!

comment:5 in reply to: ↑ 4 Changed on Aug 25, 2010 at 3:49:42 PM by dkocher

Replying to opfeifer:

Similar problem here, using v. 3.3 (5552). Even though 'upload' is selected, it also DOWNLOADS FILES during the 'synchronize' operation. Sorry my Version is outdated, but there is no note about that in the version history. Will confirm if 3.5 has this solved, but I guess not?! Also, as a feature request: Upload and delete (locally) missing files would be great to maintain consistency!

You should upgrade. I only accept bug reports against the latest release and the issues noted in the ticket are the only synchronization issues known as of version 3.5.1.

comment:7 Changed on Aug 26, 2010 at 1:41:02 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.